RIP & EIGRP Flashcards
RIP Characteristics
Distance Vector IGP
Metric = Hop count (max 15)
Performs ECMP (up to 4 paths by default)
RIPv1 Characteristics
Legacy
VLSM not supported (no subnet mask info sent with routing updates)
Updates sent every 30 sec as broadcast traffic
RIPv2 Characteristics
Supports VLSM
Supports authentication
Uses multicast (224.0.0.9)
RIPv2 Configuration
From global config: Router rip Version 2 Network 10.0.0.0 (or whichever network) No auto-summary
RIPv2 Manual Summarization
From interface config (interface you’re sending the summary route out of):
ip summary-address rip 10.0.0.0 255.255.0.0
Command: View RIP configuration
show run | section rip
Command: Check RIP Database
show ip rip database
If you have RIP neighbors & don’t see expected routes, check this
Command: RIP Default Route Injection
ip route 0.0.0.0 0.0.0.0 203.0.113.2
router rip
default-information originate
(Injects the above default route into RIP)
Command: RIP Passive Interface on FastEthernet3/0 on the 203.0.113.0 network
router rip
passive-interface f3/0
network 203.0.113.0
EIGRP Characteristics
Advanced Distance Vector IGP
Supports large networks
Fast convergence time
Supports bounded updates (network topology changes only sent to affected routers)
Messages sent via Multicast
Automatic equal cost load balancing (up to 4 paths by default, can be increased to 16)
Supports unequal cost load balancing
EIGRP Configuration (10.0.0.0/16 network)
router eigrp 100
network 10.0.0.0 0.0.255.255
(Uses wildcard mask; 100 = AS number)
EIGRP Verification Commands
show run | section eigrp
show ip eigrp interfaces
show ip eigrp neighbors
EIGRP: Router ID
Used by EIGRP routers to identify themselves
Takes form of an IP address
Defaults to being the highest IP of any loopback interfaces configured, or the highest other IP address if a loopback doesn’t exist
Can be manually specified
Command: EIGRP Router ID Configuration for 2.2.2.2
router eigrp 100
eigrp router-id 2.2.2.2
Command: View EIGRP Router ID
show ip protocols
show ip int brief
(And find the highest IP of interfaces; if you have a loopback, that will be the Router ID even if it’s lower)