Cisco Device Security Flashcards

1
Q

IOS Security

A

When a Cisco router/switch is received from the factory, no security is configured

You can access the command line via console cable with no password required

One of the first tasks is to configure security to ensure that only authorized admins can access the device

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
2
Q

Basic Line Level Security

A

Minimal password security can be configured via use of static, locally defined passwords at three different levels:

Console line
–Accessing user exec mode when connecting via console cable

Virtual terminal VTY line
–Accessing user exec mode when connecting remotely via telnet/ssh

Privileged exec mode
–Entering the “enable” command

The levels can be used independently or in combo with each other
They can use the same or different passwords

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
3
Q

Basic Console Security

A

Only one admin can connect over console cable at a time so the line number is always 0

“Login” with no following keywords requires the admin to enter the password configured at the line level to log in

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
4
Q

Command: Set “Flackbox1” as the password in the console line

A

line console 0
password Flackbox1
login

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
5
Q

Basic Telnet Security

A

An admin can use telnet to connect to the CLI of a router/switch over an IP connection

IOS devices do NOT accept incoming telnet sessions by default

An IP address and virtual terminal VTY line access must be configured

Multiple admins can connect at the same time
–Lines are allocated on a first come first serve basis
–Total of 16 lines supported typically (0-15)

If all configured lines are in use then additional admins will not be able to login

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
6
Q

Command: Telnet Switch Configuration
IP: 192.168.0.10/24
Gateway: 192.168.0.1

A

interface vlan 1
ip address 192.168.0.10 255.255.255.0
no shutdown
exit

ip default-gateway 192.168.0.1

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
7
Q

Command: Configure VTY password of “Flackbox2” on all lines

A

line vty 0 15 –> configures lines 0 through 15
password Flackbox2
login

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
8
Q

Console & VTY Lines: Exec Timeout

(And command to set or remove)

A

An admin will be logged out after 10 minutes of inactivity by default
–Applies to both console & VTY lines

You can edit this value with the exec-timeout command
–No exec-timeout OR exec-timeout 0
—-Allows admin to stay logged in indefinitely

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
9
Q

Command: Change line console exec timeout to 15 minutes

A

line console 0
exec-timeout 15

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
10
Q

Command: Change VTY exec timeout to [5 minutes, 30 seconds] on all lines

A

line vty 0 15
exec-timeout 5 30

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
11
Q

Command: Configure ACL permissions for host 10.0.0.10 to access all VTY lines

VTY password: Flackbox3

A

access-list 1 permit host 10.0.0.10

line vty 0 15
login
password Flackbox3
access-class 1 in

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
12
Q

Command: Configure a login message on VTY

A

banner login “

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
13
Q

Command: Create an enable password of Flackbox3

A

enable password Flackbox3

(not encrypted)

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
14
Q

Command: Create an enable secret of Flackbox3

A

enable secret Flackbox3

(Shows as encrypted in running config)

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
15
Q

Command: Encrypt all passwords in the running config

A

service password-encryption

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
16
Q

Command: Create two users (Admin1 & Admin2) with encrypted passwords (Flackbox1 & Flackbox2)

And then add them to VTY and Console Lines

A

(From global config)
username admin1 secret Flackbox1
username admin2 secret Flackbox2

line console 0
login local

line vty 0 15
login local

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
17
Q

Privilege Levels

A

There are 16 privilege levels of admin access (0-15) available on Cisco routers/switches

Usernames can be assigned a privilege level (default is 1)

You can also configure different passwords for direct access to the different privilege levels

Each available command in IOS can be assigned a privilege level
–An admin must be logged in with a privilege level higher to run the command

18
Q

Privilege Levels: 3 Default Levels

A

All commands are at one of these 3 by default:

Zero-level access allows 5 commands
—Logout, enable, disable, help, exit

User level (1) provides very limited read-only access
—When you enter user exec you’re at privilege 1 by default

Privileged level (15) provides complete control over the router
—When you enter privileged exec, you’re at 15 by default

19
Q

Command: Display current privilege level

A

show privilege

20
Q

Command: Configure new users
Admin1 (Password Flackbox1) - Privilege 1
Admin2 (Password Flackbox2) - Privilege 15

A

username admin1 secret Flackbox1

username admin2 privilege 15 secret Flackbox2

21
Q

Command: Change “show run” command to privilege level 5

A

privilege exec level 5 show running-config

22
Q

Command: Set an enable secret of “Secret2” for level 5 privilege

A

enable secret level 5 Secret2

23
Q

Command: Enable SSH and create a domain name of flackbox.com

A

ip domain-name flackbox.com
crypto key generate rsa
768 —> Minimum key size requirement

24
Q

Command: Disable telnet on all VTY lines

Create SSH username Flackbox with password Flackbox1

Set SSH version to 2

A

username Flackbox password Flackbox1

line vty 0 15
transport input ssh
login local
exit

ip ssh version 2

25
Q

Windows CLI SSH Syntax

A

ssh -L Flackbox 10.0.0.1

(Where Flackbox is the username)

26
Q

AAA Overview

A

Authentication, Authorization, Accounting:

Configuring line level security or local usernames on each device has a serious scalability limitation
If a passwords has to be added/changed/removed, it needs to be done on all devices
An external AAA server can be used to centralize this instead
Multiple AAA servers can be implemented for redundancy

27
Q

Authentication

A

Verifies someone is who they say they are (commonly via username/password)

Mandatory if authorization/accounting are used

28
Q

Authorization

A

Specifies what a particular user is allowed to do

Optional

29
Q

Accounting

A

Keeps track of actions a user has carried out

Optional

30
Q

RADIUS Use

A

Commonly used for end user level services (ex: VPN access)

31
Q

TACACS+ Use

A

Commonly used for admin access on Cisco devices

Has more granular authorization capabilities

32
Q

Cisco AAA Servers

A

ISE (Identity Services Engine) —> Cisco’s AAA Server

Cisco also offered the ACS (Access Control Server); now deprecated

33
Q

Command: Set a login message to display after an admin logs in

A

banner exec “

34
Q

Disable Unused Services

A

It’s best practice to disable unused services
This reduces attack surface (and load on device)

HTTPS is sometimes used by GUI admin tools
—but HTTP should be disabled

CDP should also be disabled in highly secure environments

Examples:
No ip http server
No cdp run

35
Q

Time Synchronization

A

All servers & infrastructure devices should be synced to the same time

This aids in troubleshooting as logs will report the correct time that evens occurred

It is also required by several security features such as Kerberos authentication & digital certificates

36
Q

NTP

A

Network Time Protocol:
Servers & infrastructure devices can use their own internal clock or sync with an external NTP server

An NTP server should be used to ensure all devices have the same time

A Cisco router can function as an NTP server and/or client

37
Q

Command: Verify NTP Info

A

show ntp status

38
Q

Command: Verify Clock Settings

A

show clock

39
Q

Command: Configure a router to be an NTP client for the server 10.0.1.100

A

ntp server 10.0.1.100

40
Q

Command: Set the time zone to PST

A

clock timezone PST -8 –> 8 hours behind UTC

41
Q

Command: Configure a router to be an NTP server

A

ntp master