EtherChannel Flashcards
Why we have EtherChannel
End hosts do not constantly send traffic over the network
Most of the time their network connection is sitting idle
Because of this you can connect less uplinks to each higher layer than the number of hosts you have and still maintain acceptable network performance
Oversubscription Rule-of-Thumb
20:1 ratio from access layer to distribution layer
If you had 20 PCs connected with 1Gbps NICs at the access layer, you would require a single 1Gbps uplink to the distribution layer
4:1 ratio from distribution to core layer links
EtherChannel Overview
AKA: Port Channel | LAG (Link Aggregation) | Link Bundle
Groups multiple physical interfaces into a single logical interface
Spanning Tree sees EtherChannel as a single interface, so it does not block any ports
We can now get the full 20 Gbps bandwidth (regarding issue above)
Load Balancing & Redundancy:
Traffic is load balanced across all links in the EtherChannel
If an interface goes down its traffic will failover to the remaining links
NIC Teaming
AKA: Bonding | NIC Balancing | Link Aggregation
Combines multiple NICs into a single logical interface
EtherChannel Load Balancing
Packets from the same flow are always load balanced on the same interface
- Round robin load balancing is not used here
- Could cause packets to arrive out of order
Any single flow receives the bandwidth of a single link in the port channel as a maximum
A port channel can be thought of as a multi-lane motorway
-Cars stay in a single lane, but because there are multiple lanes, the overall traffic gets there quicker
EtherChannel provides redundancy & load balancing. If a link fails, the flows will be load balanced to the remaining links
EtherChannel Protocols: LACP
Link Aggregation Control Protocol:
Open standard
Switches on both sides negotiate the port channel creation/maintenance
This is the preferred method
EtherChannel Protocols: PAgP
Port Aggregation Protocol:
Cisco proprietary
Switches on both sides negotiate the port channel creation/maintenance
Static EtherChannel
Switches do not negotiate creation/maintenance
Settings must still match on both sides for port channel to come up
Use if LACP is not supported on both sides
EtherChannel Configuration Requirements
All protocols are configured with:
Channel-group
Both sides must have matching configuration: Speed/duplex Access/trunk mode Native & allowed VLANs on trunks Access VLAN on access ports
LACP Configuration
LACP interfaces can be set as Active or Passive
If SW1’s interfaces are Active, & SW2’s are Passive:
-Port channel will come up
If both sides are passive:
-Port channel will NOT come up
If both sides are active:
- Port channel will come up
- This is recommended so you don’t have to think about which side is which
Command: Configure LACP Active on interfaces F0/23 and F0/24
interface range f0/23 - 24
channel-group 1 mode active
interface port-channel 1
switchport mode trunk
PAgP Configuration
PAgP interfaces can be set as Desirable or Auto
If one side is Desirable, and the other Auto
-Port channel will come up
If both sides are auto
-Port channel will NOT come up
If both sides are desirable
- Port channel will come up
- Recommended
Command: Configure PAgP Desirable on interfaces F0/23 and F0/24
interface range f0/23 - 24
channel-group 1 mode desirable
interface port-channel 1
switchport mode trunk
Command: Configure static EtherChannel on interfaces F0/23 and F0/24
interface range f0/23 - 24
channel-group 1 mode on
interface port-channel 1
switchport mode trunk
switchport trunk native vlan 199 —> or whatever the Native VLAN is for both sides
Multi-Chassis EtherChannel
Cisco supports Multi-chassis EtherChannel tech on some switches
These switches support a shared EtherChannel from different switches
The switches must be configured with matching settings