Inter-VLAN Routing Flashcards
VLANs & IP Subnets in the LAN
Typically a 1:1 relationship between subnets & VLANs in the LAN campus
Hosts in different subnets need to send traffic via router to communicate
Router with Separate Interfaces
You need a separate physical interface for every VLAN
You’re liable to run out of interfaces
Traffic being routed within the campus has to go up & down physical ethernet cables to the router
RoaS
Router on a Stick:
You configure subinterfaces instead of using separate interfaces
There’s more contention for bandwidth in this setup
Command: Configure RoaS for F0/1
On Router:
interface f0/1
no ip address
no shut down
interface f0/1.10
encapsulation dot1q 10
ip address 10.10.10.1 255.255.255.0
interface f0/1.20
encapsulation dot1q 20
ip address 10.10.20.1 255.255.255.0
On Switch:
interface f0/1
switchport mode trunk
Command: Configure Layer 3 switch for Inter-VLAN Routing
ip routing
interface vlan 10
ip address 10.10.10.1 255.255.255.0
interface vlan 20
ip address 10.10.20.1 255.255.255.0
Layer 3 Switch WAN Routing Configuration
On the L3 switch interface connected to router:
interface f0/1 no switchport --> Must act as a layer 3 interface ip address 10.10.100.1 255.255.255.0 exit ip route 0.0.0.0 0.0.0.0 10.10.100.2
On the router interface connected to the L3 switch
interface f0/1
ip address 10.10.100.2 255.255.255.0
interface f0/2 –> connected to internet/WAN
ip address 203.0.113.1 255.255.255.0
exit
ip route 0.0.0.0 0.0.0.0 203.0.113.2
ip route 10.10.0.0 255.255.0.0 10.10.100.1