Module 19: Build a Small Cisco Network Flashcards
the command is
copy running-config startup-config
on a router or switch what is the command to
save configurations
the command is
line console 0
password password
login
on a router or switch what is the command to
secure user exec mode
on a router or switch what is the command to
secure all passwords in the config file
the command is
service password-encryption
on a router or switch what is the command to
save configurations
the command is
copy running-config startup-config
the command is
enable secret password
on a router or switch what is the command to
secure privileged exec mode
the command is
service password-encryption
on a router or switch what is the command to
secure all passwords in the config file
what is the command to
configure a local user with a password
the command is
username username secret password
what configuration must be made
before an ssh connection can be made to a switch or router
rsa keys must be generated on the device before this action can take place
describe the 5 commands involved with
configuring the switch virtual interface (SVI)
interface vlan 1 - enter this from global configuration mode to enter the interface sub configuration mode for vlan 1 (NOTE: vlan 1 is the default SVI and is assighned to all interfaces on the switch) (vlan 1 is a virtual interface)
ip address ip address subnet mask - configure the ip address and subnet mask
no shutdown - bring vlan 1 online
exit - go back to global configuration mode
ip default-gateway default gateway - configure a default gateway for the switch so it can communicate with other networks
on a router or switch what is the command to
secure remote telnet / ssh access
the commands are
line vty terminals (0 15)
password password
login
transport input {ssh | telnet | none | all}
this version must always be chosen over SSH version 1 due to known vulnerabilities
why should SSH version 2 always be used if it is available
the steps include
- set domain name
- generate rsa keys
- configure a local user with a password
- configure vty lines to accept SSH connections and require a local user login
- enable ssh version 2
what are the 5 steps for
configuring and enabling ssh
the commands are
line vty 0 15
transport input ssh
login local
exit
what are the commands to
configure vty lines 0 to 15 to accept SSH connections and require a local user login
interface vlan 1 - enter this from global configuration mode to enter the interface sub configuration mode for vlan 1 (NOTE: vlan 1 is the default SVI and is assighned to all interfaces on the switch) (vlan 1 is a virtual interface)
ip address ip address subnet mask - configure the ip address and subnet mask
no shutdown - bring vlan 1 online
exit - go back to global configuration mode
ip default-gateway default gateway - configure a default gateway for the switch so it can communicate with other networks
describe the 5 commands involved with
configuring the switch virtual interface (SVI)
why should SSH version 2 always be used if it is available
this version must always be chosen over SSH version 1 due to known vulnerabilities
what is the command to
configure a domain name
the command is
ip domain-name domain-name
on a router or a switch what is the command to check
SSH configurations
the command to check this is
show ip ssh
the command to check this is
show ip ssh
on a router or a switch what is the command to check
SSH configurations
on a router or switch what is the command to
secure user exec mode
the command is
line console 0
password password
login
on a router or switch what is the command to
secure privileged exec mode
the command is
enable secret password
what is the command to
enable ssh version 2
the command is
ip ssh version 2
what are the 7 steps involved in a
initial router configuration
steps include:
- configure device name
- secure privileged exec mode
- secure user exec mode
- secure remote telnet / ssh access
- secure all passwords in config file
- provide legal notification / banner
- save configurations
what is the command to
generate rsa keys
the command is
crypto key generate rsa
steps include:
- configure a device name
- secure user exec mode
- secure remote telnet / ssh access
- secure privileged exec mode
- secure all passwords in config file
- provide legal notification / banner
- configure the management switch virtual interface (SVI)
- save the configuration
what are the 8 steps for the
initial configuration of a switch
in order to
communicate with a switch over a network
what must it have configured
to achieve this a switch must have a
Switch Virtual Interface (SVI) configured with an ip address and subnet mask it must also have a default gateway configured
the command is
ip domain-name domain-name
what is the command to
configure a domain name
to achieve this a switch must have a
Switch Virtual Interface (SVI) configured with an ip address and subnet mask it must also have a default gateway configured
in order to
communicate with a switch over a network
what must it have configured
what are the 8 steps for the
initial configuration of a switch
steps include:
- configure a device name
- secure user exec mode
- secure remote telnet / ssh access
- secure privileged exec mode
- secure all passwords in config file
- provide legal notification / banner
- configure the management switch virtual interface (SVI)
- save the configuration
the commands are
line vty terminals (0 15)
password password
login
transport input {ssh | telnet | none | all}
on a router or switch what is the command to
secure remote telnet / ssh access
the command is
crypto key generate rsa
what is the command to
generate rsa keys
on a router or switch what is the command to
configure a device name
the command is
hostname hostname
rsa keys must be generated on the device before this action can take place
what configuration must be made
before an ssh connection can be made to a switch or router
the command is
ip ssh version 2
what is the command to
enable ssh version 2
the command is
banner motd delimiter message delimiter
on a router or switch what is the command to
provide legal notification / banner
what are the commands to
configure vty lines 0 to 15 to accept SSH connections and require a local user login
the commands are
line vty 0 15
transport input ssh
login local
exit
the command is
username username secret password
what is the command to
configure a local user with a password
steps include:
- configure device name
- secure privileged exec mode
- secure user exec mode
- secure remote telnet / ssh access
- secure all passwords in config file
- provide legal notification / banner
- save configurations
what are the 7 steps involved in a
initial router configuration
the command is
hostname hostname
on a router or switch what is the command to
configure a device name
on a router or switch what is the command to
provide legal notification / banner
the command is
banner motd delimiter message delimiter
what are the 5 steps for
configuring and enabling ssh
the steps include
- set domain name
- generate rsa keys
- configure a local user with a password
- configure vty lines to accept SSH connections and require a local user login
- enable ssh version 2