OSPF Commands Flashcards
Filter out a route from being advertised outside the area where it originates but allow local routers to still see it.
area 1 range 172.16.2.0 255.255.255.0 not-advertise
Summarize routes as they are crossing an OSPF ABR
area range [advertise|not-advertise] [cost]
router ospf 1
area 2 range 172.16.0.0 255.255.0.0
Filter routes as they are crossing an OSPF ABR
area filter-list prefix {in | out}
ip prefix-list PREFIX-FILTER seq 5 deny 172.16.1.0/24
ip prefix-list PREFIX-FILTER seq 10 permit 0.0.0.0/0 le 32
router ospf 1
area 0 filter-list prefix PREFIX-FILTER in
Filter OSPF routes from entering the RIB
ip access-list standard ACL-OSPF-FILTER
deny 172.16.3.0
permit any
exit
router ospf 1
distribute-list ACL-OSPF-FILTER in
Advertise a default route into OSPF
default-information originate [always] [metric <metric-value>] [metric-type <type-value>]</type-value></metric-value>
ip route 0.0.0.0 0.0.0.0 100.64.1.2
router ospf 1
default-information originate
Modify the OSPF reference bandwidth for dynamic interface metric costing
auto-cost reference-bandwidth <bandwidth_in_mbps></bandwidth_in_mbps>
router ospf 1
auto-cost reference-bandwidth 40000
(sets reference bandwidth to 40 Gig)
Statically set the OSPF metric for an interface
interface gig0/1
ip ospf cost <1–65535>
Configure the OSPF priority for a DR/BDR election
interface gig0/1
ip ospf priority <0–255>
Show the reference bandwidth
‘show ip ospf | i Reference