SIM questions Flashcards
In order to allow same AS prefix to be received from eBGP neighbor and installed in BGP table, R3 can use the “allowas-in” command will as below:
R3(config)#router bgp 123 R3(config-router)#address-family ipv4 R3(config-router-af)#neighbor 192.168.1.2 allowas-in
Same configuration should be applied to R1:
R1(config)#router bgp 123 R1(config-router)#address-family ipv4 R1(config-router-af)#neighbor 10.0.0.2 allowas-in
Verification:
R1,R3#show ip bgp -> see Loopback0 of remote routers.
R1 must ping Loopback0 of R3 successfully.
Save the configuration
Don’t forget to save the configuration on R1 & R3
R1, R3#copy running-config startup-config
Note: The HSRP group number, priority value… may be different in the exam so be careful!
DISTRO-SW1:
DISTRO-SW1(config)#interface Vlan 100 DISTRO-SW1(config-if)# standby 1 ip 192.168.1.1 DISTRO-SW1(config-if)# standby 1 priority 110 DISTRO-SW1(config-if)# standby 1 preempt
DISTRO-SW2:
DISTRO-SW2(config)#interface Vlan 100 DISTRO-SW2(config-if)# standby 1 ip 192.168.1.1 DISTRO-SW2(config-if)# standby 1 preempt
Don’t forget to save the configs
DISTRO-SW1#, DISTRO-SW2#copy running-config startup-config
Note:
+ The default HSRP priority is 100 so we don’t need to configure it on DISTRO-SW2
DISTRO-SW1(config)#interface vlan 100 DISTRO-SW1(config-if)#glbp 1 ip 192.168.1.254 DISTRO-SW1(config-if)#glbp 1 priority 110 DISTRO-SW1(config-if)#glbp 1 preempt delay minimum 15 //Configures the router to preempt if it has a higher priority than the current active virtual forwarder after a delay of 15 seconds
DISTRO-SW2(config)#interface vlan 100 DISTRO-SW2(config-if)#glbp 1 ip 192.168.1.254 DISTRO-SW2(config-if)#glbp 1 preempt
Don’t forget to save the configs
DISTRO-SW1#, DISTRO-SW2#copy running-config startup-config
In this sim there is only one router that we can configure so type all below commands under global configuration mode Router(config)# of this router:
track 1 interface Loopback0 line-protocol event manager applet EEM_TURNON_Lo0 event track 1 state down action 1.0 cli command “enable” action 2.0 cli command “conf t” action 3.0 cli command “int lo0” action 4.0 cli command “no shut” Router#copy running-config startup-config
Task 1. Configure OSPF without using the “network” statement under the “router ospf” configuration section.
R1,R2(config)#interface e0/0 R1,R2(config-if)#ip ospf 1 area 0 R1,R2,R3(config-if)#interface lo0 R1,R2,R3(config-if)#ip ospf 1 area 0
More on R2, R3:
R2(config)#interface e0/1 R2(config-if)#ip ospf 1 area 0
Verification
R1,R2#show ip ospf neighbor
Task 2. Ensure that all networks are advertised between the routers.
R1,R2,R3#show ip route (or “show ip route ospf” if possible) to check all advertised routes.
Task 3. Configure a single command under each Ethernet interface to prevent OSPF neighbors from participating in a DR/BDR election and ensure that no extra host routes are generated.
R1,R2(config)#interface e0/0 R1,R2(config-if)#ip ospf network point-to-point
More on R2, R3:
R2,R3(config)#interface e0/1 R2,R3(config-if)#ip ospf network point-to-point
Note: Setting OSPF to point-to-point mode results in advertised routes containing the actual subnet mask instead of the default behavior of advertising /32 for a loopback interface.
Don’t forget to save the configuration
R1,R2,R3#copy running-config startup-config
Task 1. Ensure that all networks are advertised between the routers without using the “network” statement “router ospf” configuration section.
-> So we will configure OSPF under interface mode with the “ip ospf {ospf-process} area {area-number}”:
On both R1 & R2:
R1&R2(config)#interface Ethernet 0/0 R1&R2(config-if)#ip ospf 1 area 0
Note: There is another version of this task which asks to advertise networks with “network” statements. Here is the solution in this case:
R1(config)#router ospf 1 R1(config-router)#router-id 1.1.1.1 R1(config-router)#network 192.168.0.0 0.0.0.255 area 0
R2(config)#router ospf 1 R2(config-router)#router-id 2.2.2.2 R2(config-router)#network 192.168.0.0 0.0.0.255 area 0
Task 2. Configure a single command on both routers to ensure:
+ The DR/BDR election does not occur on the link between the OSPF neighbors.
+ No extra OSPF host routes are generated.
R1&R2(config)#interface Ethernet 0/0 R1&R2(config-if)#ip ospf network point-to-point
Task 3. Use md5 authentication between the p2p links
Note: This task is optional. You may or may not see this task so please read the requirements of the sim carefully
R1&R2(config-if)#ip ospf message-digest-key 1 md5 MY_PASSWORD R1&R2(config-if)#ip ospf authentication message-digest
Verification
R1#show ip ospf interface Ethernet 0/0 Ethernet 0/0 is up, line protocol is up Internet Address 10.1.1.1/30, Area 0 Process ID 1, Router ID 1.1.1.1, Network Type POINT_TO_POINT … Message digest authentication enabled
R1#show ip ospf neighbor Neighbor ID Pri State Dead Time Address Interface 2.2.2.2 0 FULL/- 00:00:35 10.1.1.2 Ethernet 0/0
Note: The IP addresses, VLAN number may be different so please check them carefully.
Task 1. Enable archive logging on SW01
SW01(config)#archive //Enters archive configuration mode.
SW01(config-archive)# log config //Enters configuration change logger configuration mode.
SW01(config-archive-log-config)# logging enable //Enables the logging of configuration changes.
Task 2. The NetFlow Top Talkers feature has been preconfigured on R01. Enable the feature for all inbound traffic on interface E0/2 of R01.
R01(config)#interface Ethernet 0/2
R01(config-if)#ip route-cache flow //track all ingress flows on the physical and all sub-interfaces. If this command does not exist, please use the command “ip flow ingress” instead.
Verification
R1#show ip cache flow R1#sh ip flow top-talkers
Save the configuration
SW01,R01#copy running-config startup-config
R2(config)#router bgp 456 R2(config-router)#address-family ipv4 R2(config-router-af)#neighbor 10.0.0.1 as-override R2(config-router-af)#neighbor 192.168.1.3 as-override
Don’t forget to save the configuration on R1 & R3
R1, R3#copy running-config startup-config
With “as-override” configured, R3 would accept routes advertised from R1 (and vice versa) as the AS 123 was replaced by AS 456 in the AS_PATH. R3 will see the AS_PATH “456 456 i” (instead of “123 456 i”). Since the AS_PATH does not contain its own AS number so it accepts the advertised routes.