Commands Flashcards
Command used to view the routing table
show ip route
What does the bracket [120/2] mean in ip routing
[AD/hop-count]
Command to show where have a DTE or a DCE cable
show controllers interface
Command to view access-lists
show access-list
Command used to view ipv6 routing table
show ipv6 route
Command to check config NVRAM and storage left
show startup-config
Command to view specifies about a port-security on an interface
show port-security interface interface
Command to view mac address-table
show mac-address table
Command to view interfaces on Router/Switch
show ip interface brief
Command to view interfaces with ipv6 addresses
show ipv6 interface brief
Command to view parameters of a specific interface
show interface interface
Command to save running-config
copy running-config startup-config
Command to view info about each IP address currently leased to a client
show ip dhcp binding
Command to view the list of config ranges of IP addresses from each pool
show ip dhcp pool pool name
Command to view directly connected devices
show cdp neighbor
Command to view basic IP address translation info
show ip nat translations
Command to delete startup-config
# erase startup-config # reload
Command to verify NAT config and see the sending address, the translation and the destination address
debug ip nat
Commands to set password for user-exec mode
# line con 0 # password *password* # login # logging sync
Command to set password for privileged-exec mode
# enable secret *password* # service password-encryption
Commands to set up static NAT config
ip nat inside source static ip address
# interface fa0/0 # ip address *ip address* *subnet mask* # ip nat inside
# interface se0/0 # ip address *ip address* # ip nat outside
Commands to set up dynamic NAT config
ip nat pool pool name ip address ip address netmask mask
# interface fa0/1 # ip address *ip address* *subnet mask* # ip nat inside
# interface se0/0 # ip address *ip address* # ip address *ip address* *subnet mask* # ip nat outside
access-list # permit ip address wildcard mask
Commands for PAT config
# ip nat pool globalnet *ip address* *ip address* netmask *subnet mask* # ip nat inside source list *#* pool globalnet overload
# interface fa0/1 # ip address *ip address* *subnet mask* # ip nat inside
# interface se0/0 # ip address *ip address* # ip address *ip address* *subnet mask* # ip nat outside
access-list # permit ip address wildcard mask
Commands to set password for telnet
# line vty *first line num* *last line num* # password *password* # login
Command to disable DNS lookup function on a router
no ip domain-lookup
Commands to add a ipv4 address to an interface
# interface *interface* # ip address *ip address* *subnet mask*
Commands to set up ssh
# ip domain-lookup # username *name* password *password* # crypto key generator rsa
# line vty 0 15 # login local # transport input *all, telnet, ssh*
Command to set up a static route
ip route destination subnet mask next-hop
Command to set up a default route
ip route 0.0.0.0 ip address
Commands to make hosts DHCP clients
# interface *interface* # ip address dhcp
Commands to config RIP routing
# router rip # network *classful net address* # version 2 # no auto-summary
Command that prevents RIP update broadcasts from being sent to a specific interface
# router rip # passive-interface *interface*
Command to enable port-security
# interface *interface* # switchport mode access # switchport port-security
Command for security to have MAC address dynamically learned and added to running-config
switchport port-security mac-address sticky
Command for security that limits the max addresses learned to 1
switchport port-security maximum 1
Command for security that is the default violation mode and puts the interface into an error-dissabled state immediately
switchport port-security violation shutdown
Command to enable ipv6 in global-config
ipv6 unicast-routing
Command to enable IPv6 to a specific interface
ipv6 enable
Command to assign an interface with an IPv6 address
ipv6 address ip address prefix (eui-64)
Commands to config DHCP
# ip dhcp excluded-address * excluded address range* # ip dhcp pool *pool name* # network *network address* *subnet mask* # default-router *router int address* # dns-server *ip address* # lease *days hours min*
Command to view lease of DHCP
show ip dhcp binding
Command to det. next DHCP address to use
show ip dhcp pool
Commands to set up a VLAN
# vlan *2-1001/1006-4094* # name *WORD* # interface *interface* # switchport mode *access/trunk* # switchport *access/trunk* #switchport *access/trunk* vlan *2-1001/1006-4094*
Commands to config Inter-VLAN routing
# interface f0/0.1 # encapsulation dot1q *vlan num* # ip address *address* *subnet mask*
Commands to config DHCP relay
# interface *interface* # ip helper-address *dhcp server ip address*
Command to assign severity level range
logging trap severity level
Command to sync dates and times on a network
ntp server ip address version
Commands to set up standard access-list
# access-list *1-99* *deny/permit* *host/any/ip address range* *subnet mask* # interface fa0/1 # ip access-group *1-99* *in/out*
Commands to set up standard access-list to telnet/ssh
# access-list 50 permit host 172.16.10.3 # line vty 0 4 # access-class 50 in
Commands to set up extended access-list
# access-list *100-199* *deny/permit* *protocol* *source add* *dest add* # access-list *100-199* permit ip any any #interface f0/1 #ip access-group *100-199* *in/out*
Commands to set up a named standard access
# ip access-list standard *WORD* # deny *ip add* *sub mask* # permit any # exit # interface *int* # ip access-group *WORD* out
Command to show access port VLANs
show vlan
Command to show trunked ports
show interface trunk
Command to show details about a specific switchport
show interface int switchport
Command to permanently install a license on an ISR2 router
license install
Command that will copy the IOS to a backup host on your network
copy flash tftp
Command that loads a new version of the cisco IOS into a router
copy tftp flash
Distance from the reference clock
stratum
Belongs to and carries the traffic of only one VLAN
access ports (no tagging)
Way of explicitly tagging VLAN info onto an ethernet frame
Inter-switch link (ISL)
Command to map an ipv6 static unicast address?
ipv6 address address/prefix-length
Command to enable ipv6?
ipv6 address
Command to map a link-local address?
ipv6 address address link-local