1-9 - Work with VRF Instances Flashcards
IOS-XR Command:
commit
Commits changes to the running configuration.
IOS-XR Command:
configure
Enters configuration mode.
IOS-XR Command:
do
Enables you to run EXEC commands from any configuration mode.
IOS-XR Command:
export route-target [value]
Assigns an export route target to a VRF route.
IOS-XR Command:
import route-target [value]
Assigns an import route target to a VRF route.
IOS-XR Command:
interface [interface]
Enters interface configuration mode (in global configuration mode).
IOS-XR Command:
ipv4 address [ip_address/len]
Sets the IPv4 address for an interface and the subnet mask by using the prefix length format.
IOS-XR Command:
ping [dest-IP]
Verifies connectivity between the source IP and destination IP (IPv4 and IPv6) by using the global routing table.
IOS-XR Command:
ping vrf [vrf-name] [dest-IP]
Verifies connectivity between the source IP and destination IP (IPv4 and IPv6) by using the specified VRF instance.
IOS-XR Command:
neighbor [ip-address]
BGP configuration mode command. Activates the exchange of routes from the address family under the configuration for the specified neighbor.
IOS-XR Command:
neighbor [ip-address] address-family ipv4 unicast
BGP configuration mode command. Activates the exchange of IPv4 unicast address-family routes under the configuration for the specified neighbor.
IOS-XR Command:
neighbor [ip-address] address-family vpnv4 unicast
BGP configuration mode command. Activates the exchange of VPNv4 unicast address-family routes in the specified neighbor configuration.
IOS-XR Command:
neighbor [ip-address] address-family vpnv4 unicast next-hop-self
BGP configuration mode command. Configures to use the IP address of the router as a next hop for routes of the specified address family.
IOS-XR Command:
root
Returns to global configuration mode from any subconfiguration mode.
IOS-XR Command:
router bgp [as-number]
Enters to BGP configuration mode for the specified as-number.
IOS-XR Command:
router bgp [as-number] address-family ipv4 unicast
BGP configuration mode command. Enables IPv4 unicast address family in global BGP protocol.
IOS-XR Command:
router bgp [as-number] address-family vpnv4 unicast
BGP configuration mode command. Enables VPNv4 unicast address family in global BGP protocol.
IOS-XR Command:
router bgp [as-number] vrf [vrf-name]
Enter to BGP configuration mode. Enters specified vrf-name VRF configuration mode.
IOS-XR Command:
router bgp [as-number] vrf [vrf-name] address-family ipv4 unicast
BGP configuration mode command. Enters specified vrf-name VRF IPv4 unicast address-family configuration mode.
IOS-XR Command:
router bgp [as-number] vrf [vrf-name] address-family ipv4 unicast redistribute connected
BGP configuration mode command. Enables redistribution of connected routes into the specified vrf-name for IPv4 unicast address family.
IOS-XR Command:
router bgp [as-number] vrf [vrf-name] rd [rd-value]
BGP configuration mode command. Assigns rd-value as a route distinguisher to the specified vrf-name VRF.
IOS-XR Command:
show bgp neighbor
Displays BGP neighbor information.
IOS-XR Command:
show bgp vpnv4 unicast summary
Displays BGP VPNv4 address family neighbor summary information.
IOS-XR Command:
show ospf [process-id] interface brief
Displays OSPF interfaces for the specified process-id.
IOS-XR Command:
show route ipv4 ospf
Displays OSPF routes that are installed in the global routing table.
IOS-XR Command:
show route ipv4 connected
Displays directly connected routes in the global routing table.
IOS-XR Command:
show route vrf [vrf-name] connected
Displays directly connected routes in the specified vrf-name VRF.
IOS-XR Command:
show vrf all
Displays VRF information.
IOS-XR Command:
show vrf [vrf-name] ipv4 detail
Displays detailed information for the specified vrf-name VRF.
IOS-XR Command:
vrf [vrf-name]
Creates a VRF with name vrf-name.
IOS-XR Command:
vrf [vrf-name] address-family ipv4 unicast
BGP configuration mode command. Enters to vrf-name VRF address family IPv4 unicast configuration mode.
IOS-XE Command:
address-family ipv4
BGP configuration mode command. Activates and enters IPv4 address family configuration mode.
IOS-XE Command:
address-family ipv4 unicast
VRF configuration mode command. Enters IPv4 address family configuration mode.
IOS-XE Command:
address-family vpnv4
BGP configuration mode command. Enters VPNv4 address family configuration mode.
IOS-XE Command:
address-family ipv4 vrf [vrf-name]
BGP configuration mode command. Enters vrf-name VRF instance configuration mode.
IOS-XE Command:
configure terminal
Enters global configuration mode.
IOS-XE Command:
do
Enables you to run EXEC commands from any configuration mode.
IOS-XE Command:
exit
Returns to previous configuration mode.
IOS-XE Command:
interface [interface]
Enters interface configuration mode.
IOS-XE Command:
ip address [ip-address] [network-mask]
Interface configuration mode command. Assigns an IPv4 address to the configured interface.
IOS-XE Command:
ping [destination-ip]
Verifies connectivity to the specified destination-ip.
IOS-XE Command:
ping vrf [vrf-name] [destination-ip]
Verifies connectivity to the specified destination-ip in the specified vrf-name VRF.
IOS-XE Command:
neighbor [ip-address] activate
BGP configuration mode command. Activates an exchange of routes from the address family under the configuration for the specified neighbor.
IOS-XE Command:
neighbor [ip-address] next-hop-self
BGP configuration mode command. Configures the router as the next hop for a BGP-speaking neighbor or peer group (in router configuration mode).
IOS-XE Command:
neighbor [ip-address] send-community
BGP configuration mode command. Specifies that a community attribute should transmit to a BGP neighbor (in address family or router configuration mode).
IOS-XE Command:
rd [value]
VRF configuration mode command. Assigns a route distinguisher to a VRF.
IOS-XE Command:
route-target export [value]
VRF address family configuration mode command. Assigns an export route target to a VRF.
IOS-XE Command:
route-target import [value]
VRF address family configuration mode command. Assigns an import route target to a VRF.
IOS-XE Command:
router bgp [as-number]
Enters BGP configuration mode.
IOS-XE Command:
show bgp all summary
Displays BGP neighbor information for all configured address families.
IOS-XE Command:
show bgp vpnv4 unicast all summary
Displays BGP neighbor information for VPNv4 unicast address family in all VRFs.
IOS-XE Command:
show ip route connected
Displays directly connected routes in the global routing table.
IOS-XE Command:
show ip route vrf [vrf-name] connected
Displays directly connected routes in the specified vrf-name VRF routing table.
IOS-XE Command:
show vrf
Displays configured VRFs’ information.
IOS-XE Command:
show vrf detail [vrf-name]
Displays detailed information for the specified vrf-name VRF.
IOS-XE Command:
vrf forwarding [vrf-name]
Interface configuration mode command. Assigns an interface to a VRF.
IOS-XE Command:
vrf definition [vrf-name]
Creates a VRF instance.