VPN and Overlay Commands Flashcards

VPN, LISP, VXLAN

1
Q

Command to create a tunnel interface

A

Router(config)# int tunnel {number}

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
2
Q

Add an IP address to a GRE tunnel

A

Router(config-if)# ip address ip-address subnet-mask

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
3
Q

Define the source and destination of a tunnel interface

A

Router(config-if)# tunnel source {interface-id | ip-address}
Router(config-if)# tunnel destination {remote-ip-address}

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
4
Q

Define keepalives on a GRE tunnel

A

Router(config-if)# keepalives {seconds} {repeat-interval}

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
5
Q

Define the bandwidth of a GRE tunnel (optional)

A

Router(config-if)# bandwidth {kbps}

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
6
Q

Define the max MTU on a GRE tunnel (optional)

A

Router(config-if)# ip mtu {mtu-size}

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
7
Q

Adjust the TTL value on a GRE tunnel (optional)

A

Router(config-if)# tunnel ttl {1-255}

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
8
Q

The 6 commands needed to create the ISAKMP policy for the IKEv1 phase of the tunnel.

A

Router(config)# crypto isakmp policy {priority-number}
Router(config-isakmp)# hash {sha | sha256 | sha384 | md5}
Router(config-isakmp)# authentication {rsa-sig | rsa-encr | pre-share}
Router(config-isakmp)# group {1 | 2 | 5 | 14 | 15 | 16 | 19 | 20 | 24}
Router(config-isakmp)# lifetime {*0 - *}
Router(config-isakmp)# encryption {des | 3des | aes | aes 192 | aes 256}

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
9
Q

If needed for authentication, create a isakmp pre-shared key.

A

Router(config)# crypto isakmp key SHAREDKEY address peer-ip-address [mask]

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
10
Q

Creates a IPSec Transform Set

A

Router(config)# crypto ipsec transform-set NAME {transform-1} {transform-2} [transform-3]

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
11
Q

Name common transforms for ESP encryption types.

A
  • esp-aes
  • esp-aes 192
  • esp-aes 256
  • esp-seal
  • esp-gcm
  • esp-gmac
How well did you know this?
1
Not at all
2
3
4
5
Perfectly
12
Q

Name common transforms for ESP authentication types.

A
  • esp-sha-hmac
  • esp-sha256-hmac
  • esp-sha512-hmac
  • esp-md5-hmac
How well did you know this?
1
Not at all
2
3
4
5
Perfectly
13
Q

Create an IPSEC profile and associate a Transform Set.

A

Router(config)# crypto ipsec profile NAME
Router(ipsec-profile)# set transform-set TRANS-SET-NAME

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
14
Q

Specify the ipsec tunnel mode

A

Router(config)# int tunnel number
Router(config)# tunnel mode ipsec {ipv4 | ipv6}

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
15
Q

Apply the IPSec Profile to the tunnel

A

Router(config)# int tunnel number
Router(config-if)# tunnel protection ipsec profile PROFILE-NAME

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
16
Q

Create a crypto access-list to define encrypted traffic for the tunnel (2 commands)

A

Router(config)# ip access-list extended NAME
Router(config-acl)# permit gre host {tunnel-source-ip} host {tunnel-destination-ip}

17
Q

Create a Crypto-Map (alternative to using IPSec Profiles) - 4 commands

A

Router(config)# crypto map NAME sequence-number ipsec-isakmp
Router(crypto-map)# match address ACL-NAME
Router(crypto-map)# set peer dest-ip-address
Router(crypto-map)# set transform-set TRANS-SET-NAME

18
Q

When creating a DMVPN or Flex VPN, what is the command to create a multipoint GRE tunnel?

A

R1(config)# int tunnel 0
R1(config-if)# tunnel mode gre multipoint

19
Q

Display information about ISAKMP Security Associations

A

Router# show crypto isakmp sa

20
Q

Display information about IPSEC security associations

A

Router# show crypto ipsec sa

21
Q

Display IPSEC connections

A

Router# show crypto engine connections active