Day 18 - Basic Router Configuration Flashcards

1
Q

For R1, perform the following tasks:

  • Give the Router a Hostname
  • Set a global enable secret
  • Set a username and password users will use to remote in via SSH
  • Set the password for the Console port
  • Set the VTY lines for SSH
  • Configure a banner message
  • Configure Gi0/0 for IP address 192.168.1.1 with a subnet mask of /24 and set a description on the port
  • Ensure R1 can reach 192.168.3.0 through a static route (the serial int IP address on R2 is 192.168.2.2)
  • Verify the config
  • Verify the routes have made it into the routing table
  • Verify the interfaces are IP’d correctly
  • Verify the interfaces with a global show command
  • Save the changes to the startup config
A

hostname R1
enable secret cisco
username admin password cisco

line con 0
password cisco
login

line vty 0 15
transport input ssh
login local

banner motd # message #

int gi0/0
ip address 192.168.1.1 255.255.255.0
no shutdown
description Link to SW1

ip route 192.168.3.0 255.255.255.0 192.168.2.2

show running-config
show ip route
show ip int brief
show interfaces

copy run start

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
1
Q

What command would you use to encrypt all plaintext passwords on a router or switch?

A

service password-encryption

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
2
Q

Solve for the interface status code scenario:

Refers to the layer 1 status. For example, is the cable installed? Is it the right, wrong cable? Is the device on the other end powered on?

What are some things you might see here?

A

Line status

administratively down
up
down

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
3
Q

Solve for the interface status code scenario:

Refers generally to the layer 2 status. It is always down if the line status is down. If the line status is up, this type of status of down is usually caused by mismatched data link layer configuration

What are some things you see here?

A

Protocol status

down
up

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
4
Q

Solve for definition of interface status code:

The interface has a shutdown command configured on it

A

Administratively down / down

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
5
Q

Solve for definition of interface status code:

The interface has a no shutdown command configured, but the physical layer has an issue. For example, no cable has been attached to the interface, the switch interface on the other end of the cable is shut down or the switch is powered off

A

down/down

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
6
Q

Solve for definition of interface status code:

This almost always refers to data link layer problems, most often configuration problems. For example, serial links have this combination when one router configured to use PPP and the other defaults to use HDLC

A

up/down

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
7
Q

Solve for definition of interface status code:

All is well and the interface is functioning

A

up/up

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
8
Q

What granular command could you use to check a myriad of settings on an interface?

A

show interface {int}

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
9
Q

What is the difference between the show interface {int} and show interface {int} switchport command

A

show interface {interface} provides general information about the interface while the second command show interface {interface} switchport provides specific details about the switchport configuration of the interface, especially on switches.

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
10
Q

What command would you use to enable IPv6 routing?

A

ipv6 unicast-routing

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
11
Q

This command configures the router to begin listening for and responding to Neighbor Discovery (ND) messages on all active IPv6 routers

A

ipv6 unicast-routing

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
12
Q

What command would you use to configure an IPv6 address to use EUI-64? Use the global routing prefix and subnet ID of 2001:db8:acad:1::/64 to achieve this

A

ipv6 address 2001:db8:acad:1::/64 eui-64

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
13
Q

What command would you use to configure an IPv6 global unicast address manually? Use the IPv6 address 2001:db8:acad:1:0:0:0:1

A

ipv6 address 2001:db8:acad:1::1/64

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
14
Q

True or False:

It is generally good practice to manually configure the IPv6 link-local address?

A

True

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
15
Q

What command would you use to manually configure an IPv6 link-local address?

A

ipv6 address fe80::1 link-local

16
Q

If you add an IPv6 address using EUI-64 and then want to manually assign a single IPv6 address to that interface what command must you use to remove the EUI-64 address?

Why must you do this?

A

no ipv6 address {ipv6-address} eui-64

If you don’t issue this command the interface will have two IPv6 addresses associated with it

17
Q

What command would you use to verify the full configuration of an IPv6 interface?

A

show ipv6 interface {int}

18
Q

What does an unsuccessful ping show?

A

5 periods

…..

19
Q

What does a successful ping show?

A

5 exclamation marks

!!!!!

20
Q

What does an unsuccessful traceroute show?

A

Asterisks

21
Q

What command in CMD would you use to SSH into a router with the ip address 10.10.10.1 with the username admin?

A

ssh -l admin 10.10.10.1

22
Q

What are the 5 common SOHO connections?

A

DSL
Cable
Cellular
Satellite
Dial Up

23
Q

If you are sure you configured the IP address, subnet mask (IPv4) or network prefix (IPv6) correctly then any basic IP addressing issue likely to be the result of what?

A

Misconfigured default gateway
Duplicate addresses

24
Q

If you run into a duplicate IP address issue in the field what is the easiest way to fix it assuming the IP configuration is static?

A

Convert the host to use DHCP