Day 16 - InterVLAN Routing Flashcards
Three options are available when implementing interVLAN routing. What are they?
Traditional or legacy
Router on a stick
Multilayer / Layer 3 switching
__________ __________ routing requires multiple physical interfaces on both the router and the switch.
Legacy interVLAN
This type of interVLAN routing makes it possible to configure one router interface as multiple trunks by using subinterfaces. The single physical interface is logically subdivided into multiple logical interfaces
Router on a stick
What is the most scalable solution when it comes to interVLAN routing? It makes use of a multilayer switch to replace both the router and the switch as was used in Router on a Stick
Multilayer switching
As far as interVLAN routing is concerned, multilayer switches perform two functions; what are they?
Switching traffic within the same VLAN
Routing traffic between VLANs
Why is multilayer switching more scalable than any other interVLAN routing implementation? Give two examples
Routers have a limited number of available interfaces
One single link can limit bandwidth and amounts of traffic
When configuring interVLAN routing using the router on a stick model, the __________ __________ on the router must be connected to a __________ __________ on the adjacent switch
Physical interface
Trunk link
For router on a stick, these types of interfaces are created for each unique VLAN on the network
Subinterfaces
For router on a stick, each subinterface is assigned a unique what?
IP address
For router on a stick, each subinterface is configured to tag __________ for that VLAN
Frames
Based on the topology below and assuming the switch is already configured with VLANs and trunking
Configure both VLANs (10 and 30) to use subinterfaces on Gi0/0 on the router
Use the IP addresses in the topology
int gi0/0
no shutdown
int gi0/0.10
encap dot1q 10
ip address 172.17.10.1 255.255.255.0
int gi0/0.30
encap dot1q 30
ip address 172.17.30.1 255.255.255.0
What verification commands would you use to verify the configuration for interVLAN (router on a stick) to make sure new networks are in the routing table and the subinterfaces are up and up?
show vlans
show ip route
show ip int brief
All Catalyst multilayer switches support what two types of Layer 3 interfaces?
SVIs
Routed ports
Solve for definition:
Virtual VLAN interface used for interVLAN routing
SVI (Switched virtual interface)
Solve for definition:
Similar to a physical interface on a Cisco IOS router
Routed port
How would you create an SVI for VLAN 20 with an IP address of 10.10.20.1 on a multilayer switch?
int vlan 20
no shut
ip address 10.10.20.1 255.255.255.0
Based on the topology:
- Enable Layer 3 routing
- Create SVIs for VLANs 10 and 30
- Correctly IP those SVIs
- Put fa0/11 and fa0/6 into the correct VLANs
- Configure the egress port going to the internet to be a routed port based on the IP address
- Configure a default static route that goes out to the internet
ip routing
vlan 10
vlan 30
int vlan 10
ip address 172.17.10.1 255.255.255.0
no shut
int vlan 30
ip address 172.17.30.1 255.255.255.0
no shut
int fa0/11
sw mode acc
sw acc vlan 10
int fa0/6
sw mode acc
sw acc vlan 30
int gi0/1
no switchport
ip address 192.0.2.2 255.255.255.0
ip route 0.0.0.0 0.0.0.0 gi0/1
copy run start
Assuming the default switch configuration, which VLAN range can be added, modified, and removed on a Cisco switch?
2 through 1001