9 - Implementing OSPF Flashcards
How do you enter the OSPF configuration mode for a given OSPF process ID?
router ospf
What command is used to configure the router ID from OSPF configuration mode?
router-id
What three ways can you configure the router ID for OSPF?
- OSPF configuration mode
- Configure an IP on the loopback interface
- Rely on an interface address already configured
How would you configure OSPF using the indirect mode, i.e. mostly in the OSPF configuration mode?
router ospf 1
router-id 1.1.1.1
network 10.0.0.0 0.255.255.255 area 0
int s0/0> ip address 10.1.1.1 255.255.255.0
What information does the show ip ospf neighbor
command show you?
- Neighbor router IDs
- Neighbor state
- Neighbor Address
- Interface
What does a neighbor state of FULL/- indicate?
The link does not use a DR/BDR
What is a DROTHER neighbor?
A neighbor that is neither the DR or BDR
What command is used to show the LSDB?
show ip ospf database
True/False: DR/BDR election is done per area?
False. DR/BDR election is done per subnet
True/False: Point to point links do not have a DR/BDR election process
True
What are some commands that are useful for verifying OSPF configuration?
show ip ospf interface [brief]
show run
show ip protocols
How do you enter the configuration mode for a loopback interface?
interface loopback 0
How do you configure OSPF multi-area from OSPF configuration mode?
router ospf 1
network 10.1.1.1 0.0.0.0 area 0
network 10.1.2.1 0.0.0.0 area 2
How do you directly enable OSPF on an interface instead of using the OSPF configuration mode?
interface g0/1
ip ospf 3 area 0
How do you remove configured networks from the OSPF configuration?
no network 10.0.0.0 area 0
True/False: Wildcards are not used to configure OSPF
False
What does “Interfaces configured explicitly” imply in the output of show ip protocols
when considering OSPF?
OSPF was enabled using the interface subcommand mode (ip ospf 1 area 0)
What is the difference between the following two notes after an interface address in the output of show ip ospf interface
Attached via Interface Enable
&
Attached via Network Statement
Attached via Interface Enable implies that OSPF was enabled using the interface configuration mode. While
Attached via Network Statement means it was configured from OSPF configuration mode
What is the impact of making an interface passive in OSPF?
It won’t send OSPF Hellos, or process any received Hellos in that interface.
But it will continue to advertise the subnet that is connected to that interface
How do you make an interface passive in OSPF configuration mode per each interface?
router ospf 1
passive-interface G0/0.1
passive-interface G0/0.2
How do you configure passive interfaces in OSPF configuration mode by default but exclude certain ones?
router ospf 1
passive-interface default
no passive-interface G0/1
no passive-interface G0/2
What does the OSPF command default-information originate
do?
Makes the router advertise a default route using OSPF to remote routers
How do you make OSPF always advertise the default route even if its not working?
default-information originate always
What three ways can you change the OSPF interface cost (used to calculate SPF)?
- Setting the cost directly with interface subcommand: ip ospf cost x
- Alter the ‘bandwidth’ setting for an interface to adjust the default cost calculation
- Alter the ‘auto-cost reference-bandwidth’ setting in ospf router config mode to adjust the default cost calculation
What command is used to adjust the bandwidth speed for an interface?
bandwidth [speed in kbits]
What is the formula used to calculate the cost metric?
Reference bandwidth / interface bandwidth
Why should you avoid altering the interface bandwidth to adjust OSPF cost calculation?
Because several other IOS features make use of this setting
How do you adjust the reference bandwidth?
auto-cost reference-bandwidth
What does the maximum-paths command do?
Configures the maximum number of equal cost OSPF routes allowed in the routing table
What is the difference between Point to point and broadcast OSPF network types with respect to DR/BDRs?
Point to Point does not utilize a DR/BDR
What type of OSPF network type does OSPF default to on Ethernet interfaces?
Broadcast
What command would you use to show you the OSPF network type?
show ip ospf interface
What command would you use to configure OSPF to broadcast network type when it is not the default?
Interface subcommand:
ip ospf network broadcast
True/False: If the ‘best’ router / current DR fails but comes back up, it will immediately become the DR again
False. It will not be DR again until the current DR AND BDR fail
What are the two things you can use to influence the DR/BDR election in order of precedence?
- Highest OSPF interface priority
2. Highest OSPF Router ID
What are the two key differences between an STP election process and DR/BDR election process?
- In STP new switches can preempt the current root (overtake it) but this doesn’t happen with DR/BDRs in OSPF
- STP uses lowest is best approach (RouterID) whereas OSPF uses highest is best
What is the default OSPF priority value?
1
What kind of OSPF network type would you want for a link that by its nature has just two routers on the link? I.e. Serial or PTP Ethernet WAN
Point to point
What is an Ethernet Private Wire Service / E-Line?
PTP Ethernet WAN.
Only two devices on the link sending / receiving Ethernet frames
What does the - mean in the state output for a neighbor when using the show ip ospf neighbor
command?
The link does not use a DR/BDR
What does each field mean in the Nbrs column output of the show ip ospf interface brief
command? i.e 2/5
Fully adjacent neighbors/total neighbors
What are the neighbor requirements that must match for OSPF neighbors?
- Unique Router ID
- ACLs not filtering routing protocol messages
- Interfaces same subnet
- Pass neighbor authentication (if enabled)
- Same Area
- Hello/Dead timers must match
- MTU setting
- OSPF network type
What two neighbor requirement settings for OSPF can be incorrect but still cause the neighbor to show in the neighbor table? What can go wrong if they don’t match?
- MTU setting
- OSPF network type
Neighbor relationship listed by LSAs will not exchange correctly
Whats the easiest command to check if the Hello and dead timers match for OSPF neighbors?
show ip ospf interface g0/0
How can you easily list the OSPF Router ID?
show ip ospf
How can you enable / disable and OSPF process?
router ospf 1
[no] shutdown
What happens when a given OSPF process is shutdown?
- Neighbor relationships down and table cleared
- LSDB cleared
- Clear routing table of OSPF routes
What does OSPF retain / show in command outputs even when an OSPF process is brought down?
- All OSPF configuration
- Lists all OSPF enabled interfaces but in a down state
What is the MTU size?
Per interface setting defining the largest network layer packet the router will forward out a given interface
What is the default MTU size on many routers?
1500 bytes
What commands configure the MTU for IPv4 and IPv6?
ip mtu
ipv6 mtu
What three key things happen when two routers with mismatched OSPF network types connect?
- They become fully adjacent neighbors
- They exchange LSDBs
- Routes NOT added to IP routing table (due to difference in expected values in LSAs)