2 - Ethernet LANs Flashcards
What is the default baud rate for a console port?
9600 bits/second
What are the default console port settings?
9600 baud. No hardware flow control. 8N1 (8bit ASCII, No parity bits, 1 stop bits)
What are three common CLI access methods?
Console, Telnet, SSH
What is another name for User mode?
EXEC mode
What is another name for privileged mode and what console prompt denotes this mode?
Enable mode. #
What mode do you have to be in to reload a switch?
Enable mode
What two points in the login process can you configure simple passwords for?
- When the user connects from the console
2. When any user moves to Enable mode
What command is used to set a password to enter Enable mode?
enable secret password123
What commands would you use to set a password on the console line?
line console 0
login
password password123
How do you move from Enable mode to Global Config mode?
Use the config
command
What command do you use to move back to Global Config mode from other sub-command modes?
exit
Where are Cisco IOS images stored by default on devices?
Flash memory
Where is the startup configuration file stored?
NVRAM
Where is the bootstrap / boot-helper program stored?
ROM
What does the bootstrap program do?
Finds the full Cisco IOS image and manages the process of loading the IOS into RAM
What are three commands you can use to erase the startup config file?
erase startup-config
write erase
erase nvram:
How does a Switch learn a MAC address?
By examining the source address of the frame it receives from a device
What is the CAM table?
Memory construct on switches to store a MAC address and the associated physical port it is on. Also stores the VLAN number
What are two alternative names for the CAM table?
Switching table. Bridging table
What does a switch do with a frame it receives for a destination not yet in the CAM table?
Floods the frame out all ports except the one it was received on, with an Ethernet broadcast address of FF:FF:FF:FF:FF:FF
What are the three primary features of LAN switches?
- Forward / filter Ethernet frames
- Preparing to forward frames by learning MACs
- Prevent network loops (STP)
What does STP do?
Prevent network loops by blocking some ports from forwarding frames so that only one active path exists between any pair of LAN segments. Without it, frames could loop indefinitely, flooding process can completely congest LAN
What is the default VLAN for Cisco switches?
VLAN 1
What command is used to show the MAC address table on a Switch?
show mac address-table
How would you show all Dynamically added MACs on a Switch?
show mac address-table dynamic
What command would delete VLAN configuration details on a Switch?
delete vlan.dat
What does the Type column show in the output of show mac address-table on a switch?
How the MAC was learned, e.g. dynamically or static (entered manually)
How do VLANs impact switching logic?
For a given port, the Switch generally only forwards out frames on the VLAN that port is on
What command could you use to show the status of interfaces on a Switch?
show interfaces status
What command shows statistics about incoming and outgoing frames on interfaces?
show interfaces f0/1 counters
How do you view the details in a MAC address table for just a specific MAC, specific interface, and specific VLAN?
show mac address-table dynamic address 0200.1111.1111
show mac address-table dynamic interface f0/1
show mac-address-table dynamic vlan 1
What does a Switch do with respect to an incoming frame and aging?
Examine the source MAC, reset the inactivity timer back to 0 for that MACs entry
What command is used to change the MAC address table aging timer?
mac address-table aging-time [vlan vlan-no]
What does a Switch do when it needs to add a new MAC table entry but the table is full?
Removes the oldest entry, even if it is younger than the aging time setting
How do you remove a dynamic entry from a MAC table
clear mac address-table dynamic
- vlan
- interface
- address
What are the three main planes of a networking device?
Data plane
Control plane
Management plane
What is the main function of the data plane of a Switch?
The work done to forward frames generated by devices connected to the Switch. The main purpose of the switch.
What does the control plane do?
Configuration and processes that control and change the choices made by the data plane e.g. which interfaces are enabled, what speeds ports run at etc
What does the management plane do?
Deals with managing the device itself.
What is the difference between enable secret and enable password?
The enable secret command means the password is ‘encrypted’ (stored with MD5)
What commands would you use to enable a password on the console?
line console 0
login
password pass123
What commands would you use to enable a password on VTY lines?
line vty 0 15
login
password pass123
How would you set a password for enable mode?
Command: enable secret pass123
How would you enable local usernames and passwords for VTY lines?
username kboyle secret pass123
line vty 0 15
no password (if needed to clear)
login local
What are AAA servers used for?
Authentication, Authorization, Accounting servers hold usernames and passwords for switches and routers
What protocols would be typically used between a Switch/Router communicating to a AAA server?
TACAS+ or RADIUS
What three commands are needed additionally to support SSH on a Switch?
hostname sw1
ip domain-name example.com
crypto key generate rsa
Which command would you use to configure / control which protocols a switch supports on its VTY lines?
transport input
How do you configure a Switch to only support SSH version 2?
ip ssh version 2
What is the default protocol setting for VTY lines on Cisco routers?
None. You need to set it using the transport input command to enable Telnet/SSH into a router
What commands would you use to view information about the status of SSH on a switch?
show ip ssh
show ssh
What information does the show ip ssh
command show? How is it different to show ssh
?
Status information about the SSH server itself. The show ssh command lists information about connections
What information does the show ssh
command show?
Information about each SSH client
Why would you need an IP address on a Switch?
To allow IP based management protocols e.g. SSH access, SNMP etc
What is a SVI and what is its purpose?
Switched Virtual Interface. Also called a VLAN interface. Acts as the switches NIC, so an IP can be assigned.
What is the downside of configuring the IP / mask on one VLAN interface on a Switch?
The switch cannot communicate outside the local subnet. Unless you set the default gateway for the Switch.
Why would you need to set a default gateway on a Switch?
To allow it communicate outside the local subnet it’s on for management purposes.
How would you configure IPv4 on a Switch?
interface vlan 1 ip address 192.168.1.5 255.255.255.0 no shutdown ip default-gateway 192.168.1.1 (Optional DNS) ip name-server
How do you configure a Switch to learn its IP from DHCP?
interface vlan 1
ip address dhcp
no shutdown
How do you view DHCP information?
show dhcp lease
Switches don’t store DHCP learned info in the running config file
How do you view the status of a VLAN interface on a Switch?
show interfaces vlan 1
What command shows command history from the buffer?
show history
How do you disable / re-enable display of log messages to the console?
no logging console and logging console
What command would you use to only display log messages at appropriate times?
logging synchronous
How do you change the inactivity timeout for console and VTY?
exec-timeout mins secs
0 0 for never
How do you stop IOS attempting to resolve hostnames into IP addresses from the Switch console?
no ip domain-lookup
What command could you use to show the status, speed, duplex, vlan, and description of interfaces?
show interfaces status OR show interfaces OR show interfaces F0/1 status
How could you configure multiple interfaces at once?
The interface range command.
interface range Fe0/1-10
What is the default speed and duplex configuration on Cisco Catalyst switches?
speed auto
duplex auto
How does auto-negotiation work?
Protocol messages flow outside the normal Ethernet electrical frequencies as out of band signals over the UTP cable, where each node states what it can do, and each node picks the best options that both support
What is a key thing about UTP wiring that auto-negotiation relies on?
That 10, 100, and 1000 BASE-T use the same wiring pinouts (1000BASE-T just adds to them)
How can you disable auto-negotiation on a Switch?
Set both the speed and duplex manually
What are the default fallback settings for speed and duplex if auto-negotiation fails according to the IEEE standard?
Slowest Speed (often 10Mbps) Half Duplex for (10/100) otherwise Full
What are the default settings for speed and duplex on Cisco devices if auto-negotiation fails?
Cisco devices can sense the Speed without auto-negotiation, but if that fails then use the IEEE default
Duplex is the same as IEEE (Half duplex for 10/100, Full otherwise)
What is true about duplex for links with speeds equal to or faster than 1 Gbps
They always use Full Duplex
How does the use of a LAN hub in a network affect auto-negotiation?
Hubs do not react to auto-negotiation messages, and they do not forward them. Devices must use IEEE rules, which is often 10/Half Duplex
What does line status generally refer to?
If Layer 1 is working
What does protocol status generally refer to?
If Layer 2 is working
What interface status would be displayed for a line/protocol status of either 1. down/down or 2. up/down
notconnect
What could an interface status of notconnect suggest?
Bad cable
Bad pinouts
Speed mismatch
Neighbor device or interface off or shutdown
What would an interface status of err-disabled mean?
Port security has disabled the interface
What does “a-“ mean before a speed or duplex value in the show interfaces status command?
Value was auto-negotiated
What type of error would a Cisco switch record for a frame that failed FCS?
CRC error
What is a Runt frame?
A frame that did not meet the minimum frame size requirement (64bytes inclusive of source/dest MAC and FCS)
What is a Giant frame?
Frame that exceed the maximum frame size requirement (1518 bytes)
What is the minimum frame size requirement?
64 bytes
What is the maximum frame size requirement?
1518 bytes
What does the Frame error counter represent?
Frames received that have an illegal format e.g. partial byte. Can be cause by collisions
What is the Output errors counter representing?
Frames that failed to transmit and a problem occurred
What is the Collisions counter?
Counter of collisions that occurred when an interface was transmitting a frame
What is a Late Collision?
Subset of all collisions that occur after the 64th byte of a frame has been transmitted. In proper working LAN collisions should occur within the first 64 bytes
What do Late Collisions potentially mean is wrong with a link?
Duplex mismatch
What might be causing CRC errors to grow but not collision counters?
Interference on the cable