Trunks Flashcards
802.1Q encapsulation
802.1Q tage inserted between source and Type frield in IP header
32 bits length (4 bytes)
2 main fields in tag:
- Tag Protocol Identifier (TPID)
16 bits (2 bytes)
Always set to 0x8100, which indicates that its tagged - Tag Control Information (TCI)
- PCP - Used for Class of Service which prioritizes important traffic in congested networks
- DEI - Indicates frames that can be dropped if the network is congested
- VID - VLAN ID - Identifies the VLAN the frame belongs to. 12 bits in length
Trunking Protocols
ISL (Inter Switch Link) - Cisco proprietary protocol. Not used anymore
802.1Q
Native VLAN
VLAN 1 by default
Switches dont add 802.1Q tag to frames in the native VLAN
When a swicth recieves an untagged frame on a trunk port it assumes it belongs to the native VLAN
Configure trunks
SWI(config-if)#switchport trunk encapsulation dot1q
SWI(config-if)#switchport mode trunk
Show VLAN Trunks in CLI
SWI(config-if)#show interfaces trunk
Configure VLANS allowed on a trunk
SWI(config-if)#switchport trunk allowed vlan [VLAN]
WORD - VLAN IDs
add - add VLANs to current list
all - all VLANs
except - all VLANs except the following
none - no VLANs
remove - remove VLANs from current list
Configure Native VLAN
SWI(config-if)#switchport trunk native vlan [VLAN]
Configure a Router on a stick in CLI
R1(config-if)#interface g0/0.10
R1(config-subif)#encapsulation dot1q 10
R1(config-subif)#ip address [IP] [subnet]
R1(config-subif)#interface g0/0.20
R1(config-subif)#encapsulation dot1q 20
R1(config-subif)#ip address [IP] [subnet]
R1(config-subif)#interface g0/0.30
R1(config-subif)#encapsulation dot1q 30
R1(config-subif)#ip address [IP] [subnet]
2 methods of configuring the native VLAN on a router
encapsulation dot1q [VLAN] native
configure the IP address for the native VLAN on the routers physical interface
What is DTP (Dynamic Trunking Protocol) ?
Cisco proprietary protocol that allows Cisco switches to dynamically determine their interface status (access or trunk) without manual configuration. DTP will not form a trunk with a router. Two options:
Auto - will not actively try to form a trunk
Desirable - will actively try to form a trunk
Not used commonly
What is VTP (VLAN Trunking Protocol) ?
Allows you to configure VLANS on a central VTP server and other servers (VTP clients) will synchronize their VLAN database to the server so you dont have to configure each VLAN on each switch. Server, Client and Transparant modes.
Not used commonly
CLI command to show VTP status
show vtp status