N2:Ch0 Switch IOS Commands Flashcards
configure terminal
enters global configuration mode.
vlan vlan_id
assigns an id
exit
returns to the previous level; exits session at priv. exec
interface interface_id
access specified interface
switchport mode access
sets a switchport for information access/exchange
switchport access vlan vlan_id
assigns an interface to a specific VLAN
ip address ip_address subnet_mask
assigns ip address / subnet to interface
interface vlan vlan_id
access interface configuration for a VLAN
no shutdown
activates interface
end
returns to priv. exec mode;
copy running-config startup-config
copies running config to the startup config - saves running config
ip default-gateway ip_address
assigns default gateway for switch
duplex {**full | half | auto**}
sets duplex setting of interface to full, half , or auto
speed speed_value
sets speed of interface to 10, 100 or 1000
mdix auto
enables MDIX auto cable simulation/ select
show interfaces
shows information about all interfaces; can use “brief” , “switchport” arguments among others
show history
shows list of recently given commands; level specific
show flash
displays information about flash /NVRAM
show ip switchport
displays ip information for switchports
show mac-address-table / show mac address table
displays information about the MAC address table
show ip ssh
displays SSH information if switch uses it
ip domain-name domain_name
configures ip domain name of switch (network) at global config level
crypto key generate rsa
generates RSA key to use; 512 or 1024 modulus used
crypto key zeroize rsa
global config command used to delete RSA key and disable SSH server
username secret password
sets user name and password for SSH
line vty vty_line_id(s)
accesses specified vty lines; 0 through 15 in this case
transport input ssh
enables SSH on selected VTY lines
login
requires login with local authentication
ip ssh version 2
enables SSH V2 via global config.
switchport port-security
enables port security on interface selected
switchport port-security maximum
sets max. number of secure address allowed on a port
switchport port-security mac-address sticky
enables sticky learning of MAC addresses
ntp server ntp_server_ip
allows switch to synchronize to NTP server whose ip address is provided
ntp master {0-15 stratum value}
allows switch to synchronize to other switches/devices
show ntp associations
priv. exec mode that indicates IP address of any devices that are synced to current device, statically configured peers , and stratum number
show ntp status
user exec command that displays NTP sync status, peer the device is synced to and which NTP strata the devices is functioning in.