N2:Ch0 Cisco IOS Procedures Flashcards
Create VLAN w/ interface assignment
- vlan vlan_id - assigns VLAN id number
- name vlan_name
- exit
- interface interface_id
- switchport access vlan - sets vlan to interface
Configure Management Terminal (vlan w/ IP)
- configure terminal
- interface vlan vlan_id - enters config mode for vlan
- ip address ip_address subnet_mask
- no shutdown
Configure Default Gateway
- configure terminal
- ip default-gateway ip_address
Configure Duplex, Speed, and MDIX
- configure terminal
- interface interface_id
- duplex {full | half | auto}
- speed {10,100,1000,auto}
- mdix auto - enables MDIX for auto cable select
Configure SSH (10)
- show ip ssh - displays presence of SSH on switch
- configure terminal
- ip domain-name domain_name - sets domain name
- crypto key generate rsa
- username secret password - sets user / pw
- line vty 0 15 // Select lines to apply SSH to.
- transport input ssh - enables ssh on selected vty lines
- login - authentication done on switch vs server
- exit - returns to global config
- ip ssh version 2 - enables ssh v2 - recommended
Configure Dynamic Port Security (3)
- interface interface_id
- switchport mode access
- switchport port-security - enables port security
Configure Sticky Port Security (5)
- interface interface_id
- switchport mode access
- switchport port-security
- switchport port-security maximum - max number of secure address allowed on port.
- switchport port-security mac-address sticky- enables sticky learning
Creating a VLAN (4)
- configure terminal
- vlan vlan_id
- name vlan_name // assigns unique name to vlan
- end // returns to Priveleged Exec
Assigning Port to a VLAN (5)
- configure terminal
- interface interface_id
- switchport mode access
- switchport access vlan vlan_id
- end // returns to Privilege Exec.
Removing VLAN from Port (4)
- configure terminal
- interface interface_id
- no switchport access vlan vlan_id //removes vlan from designated port.
- end // returns to Privileged Exec.
Configure Switch for IP Address (6)
- configure terminal
- interface vlan_id
- ip address ip_address subnet_mask
4. no shutdown
- exit //returns up one level or global config.
- ip default-gateway default_gateway_ip_address
Secure Router Management (12)
- enable
- configure terminal
- enable secret password
- line console 0
- password console_password
- login
- exit
- line vty 0 4
- password vty_password
- login
- exit
- service password-encryption
Set Banner Message (2)
- configure terminal
- banner motd ! Message to be Displayed ! // ! can be any delimiting char. that is not in banner message.
Backing up Running Configuration
copy running-config startup-config
Reset Switch to Factory Start
- erase-startup config
- delete vlan.dat
- reload
Configure Loopback Device
- interface loopback loopback_id
- ip address ip_address subnet_mask
- exit
Legacy InterVLAN Switch Configuration
- configure terminal
- vlan vlan_id
- name vlan_name
- interface interface_id
- switchport access vlan vlan_id // sets vlan to the above designated interface.
- exit
- Repeat for each additional VLAN / interface combination needed.
Legacy InterVLAN Router Configuration
- configure terminal
- interface interface_id
- ip address ip_address subnet_mask
- no shutdown
Repeat process for each additional interface needed for other VLANs.
Router-On-A-Stick Switch Configuration
- configure terminal
- vlan vlan_id
-
name vlan_name
* 4.* interface interface_id - switchport mode access
- switchport access vlan vlan_id
- interface interface_connected_to_router_id
- switchport mode trunk
- exit
Router-On-A-Stick Router Configuration
- configure terminal
- interface interface_id.subinterface_id //subinterface should have same id as vlan_id
- encapsulation dot1q vlan_id
- ip address ip_address subnet_mask
- Repeat for each additional subinterface required.
- exit
- interface master_interface_id_for_subints.
- no shutdown // activates all subinterfaces at same time.
Configure Single-Area OSPF on Router (3)
-
router ospf ospf_process_id
* 2.router id router_ip_address*
* 3. network network_ip_address wildcard_mask area area_number*
Repeat Step 3 for all networks OSPF is advertising on.