ICND1 Section 6 - IP Services - ACLs Flashcards
What are the ranges for standard ACLs?
1-99
1300-1999
Syntax for an extended numbered ACL
access-list access-list-number {deny | permit} protocol source IP wildcard mask destination IP wildcard mask [log]
3 primary differences that named ACLs have vs numbered
- Names instead of numbers
- Uses ACL subcommands vs global commands to define the ACL
- ACL editing allows users to edit delete and add individual lines
Command to delete a line from a numbered ACL with sequence numbers.
conf t
ip access-list {standard | extended} number
no seq number
Syntax to assign an ACL to a vty
access-class number {in | out}
Command to set a router to use an NTP server
conf t
ntp server server {version version}
2 commands to see how NTP is working on a router
show ntp status
show ntp associations
What does “inside local” refer to?
Private IP’s used in NAT
What does “inside global” refer to?
Public IP’s used in NAT
3 steps to configure a router to do static NAT
- Set up an interface as inside local
- Set up an interface as inside global
- Create a mapping between inside and outside IP’s
Command to make an inside NAT interface
conf t
int gi0/0
ip nat inside
Command to make an outside NAT interface
conf t
int gi0/1
ip nat outside
TCP version of an extended ACL
access-list access-list-number {deny | permit}tcp source source-wildcard [operator [port]] destination destination-wildcard [operator [port]] [log]
Command to create a static NAT mapping
ip nat inside source static inside local inside global
Command to see static NAT mappings
show ip nat translations
5 steps to configuring dynamic NAT
- Set an interface to inside
- Set an interface to outside
- Create ACL for the inside interface which identifies packets for which NAT should be performed
- Create a pool of global IP’s for use in NAT
- Bind the ACL and the pool together, enabling dynamic NAT
Command to create an IP address pool for use with NAT
ip nat pool name first IP last IP netmask subnet mask
Command to bind pool and ACL together to enable dynamic NAT
ip nat inside source list ACL # pool pool name
Command to clear the NAT translation table
clear ip nat translation *
2 variations to enable PAT
ip nat inside source list ACL # interface interface overload
ip nat inside source list ACL # pool pool name overload
If an ACL omits the wildcard mask, what is the implied mask?
0.0.0.0
What are the ranges for extended ACLs?
100 - 199
2000 - 2699
Syntax for a standard numbered ACL
access-list {1-99 | 1300-1999} {permit | deny} [subnet wildcard mask | any ]
Operational command to see:
- IPv4 ACLs - All ACLs
show ip access-lists
show access-list
Command to see access list application status on an interface
show ip interface interface
Keywork to add to an ACL to help keep track of it’s activity
log
Keyword to run an operational command from inside of config mode
do
What are the 3 types of ACLs?
Standard
Extended
Named
Are named ACLs standard or extended?
Either, depends on how they are configured
What is the difference between standard and extended ACLs?
Standard ACLs filter on source address Extended ACLs filter on: Source and Dest IP Source and Dest Port Other criteria
What do extended ACLs filter on?
Source & Dest. IP
Source & Dest. Port
Others
Command to implement an ACL on an interface
ip access-group number {in | out}
ACL keyword that means “0.0.0.0” wildcard
host
ACL keyword that means 0.0.0.0 255.255.255.255
any
ACL keywords for
greater than
less than
equal to
gt
lt
eq
Command to apply an ACL to an interface
conf t
interface gi1/0
ip access-group ACL # in | out
Command to instantiate a named ACL
ip access-list {standard | extended} name
If a numbered ACL doesn’t use sequence numbers, how would a user remove one of it’s lines?
They can’t. The ACL must be deleted and re-added entirely.
What effect does the log keyword have on an ACL?
It sends messages to the log file about the activity pertinent to that line in the ACL
Command to set a static translation
ip nat inside source static inside local IP inside global IP
Command to set an inside local interface
conf t
interface interface
ip nat inside
Command to set an inside global interface
conf t
interface interface
ip nat outside
When doing static NAT, how many lines are needed to set up the mappings?
1 line per inside local IP that will be used.