EIGRP COPY Flashcards
Are keys case sensitive?
Yes
If there are multiple valid, matching keys, which key will be used?
The one with the lowest number (first match)
Give the command to display a key chain
show key chain
What are the two ways to add interfaces to EIGRP and what are the administrative distances for these?
network command - Internal route - AD 90
redistribute connected command - External route - AD 170
What two things does “passive-interface” do?
It stops the interface from sending Hello packets and will also ignore incoming ones.
Give the command to set all interfaces as passive except Ethernet0/0
router eigrp
passive-interface default
no passive-interface Ethernet0/0
What command will show EIGRP interfaces in passive mode?
sh ip protocols
Which K-values are used in the default metric?
bandwidth (k1) and delay (k3)
How is the router-id chosen?
The highest numbered active loopback is used, or the highest numbered active interface if no loopback is available.
Can two routers with the same router-id become neighbors? Can they exchange routes?
They can become neighbors but cannot exchange routes if directly connected to each other. They will accept internal routes if there is another router between the two.
Give the command to manually set a router-id
router eigrp 100
eigrp router-id X.X.X.X
What extra information does an external route update include?
It includes the originating router’s router-id as well as the external metric and protocol.
Give the command to disable split-horizon for EIGRP on an interface.
interface serial0/0
no ip split-horizon eigrp
What does the following command do?
interface serial0/0
no ip split-horizon
It will disable split-horizon for RIP only.
How much bandwidth total will EIGRP use on a given link?
By default, EIGRP uses only 50% of the available bandwidth.
Give the command to change the percentage of bandwidth EIGRP will use on interface serial0/0.
interface serial0/0
ip bandwidth-percent eigrp
Explain the difference between access-rate and CIR.
Access rate is the fastest rate a connection can physically handle. Committed information rate (CIR) is the guaranteed available rate.
Does the bandwidth command set the access rate or the CIR? Without it, what is used?
It sets the CIR. Without the bandwidth command, the CIR defaults to the access rate.
What unit does the bandwidth command use?
kilobits per second
What is the assumed bandwidth rate on a serial interface unless otherwise specified?
1544 kbps
What should the bandwidth command be set to for point-to-point and multipoint links?
On point-to-point, use bandwidth to set the CIR. On multipoint, set bandwidth to the sum of all the CIRs.
How does EIGRP determine the available bandwidth in multipoint links?
Bandwidth should be set to the sum of the CIRs. EIGRP will divide this by the number of PVCs, and use 50% of that value for each connection.
What impact does “set ip bandwidth-percent” have on a multipoint link?
EIGRP will divide the number given by the number of PVCs.
How is the reported distance sent?
The sending router sends the raw values and the receiving router calculates the reported distance (RD).
How does as a receiving router calculate the feasible distance?
It adds the delay for the distance to the sending router, and also replaces the bandwidth value if the bandwidth between it and the sending router is slower than the current minimum bandwidth, then recalculates.
What are the values given as (x, y) in “show ip eigrp toplogy”?
(feasible distance, reported distance)
What unit is used in the “delay” command on an interface? What unit is displayed with “show interface”?
The delay command uses tens of microseconds but the show command will display it in microseconds.
What are the two ways of manipulating EIGRP metrics?
1) Change delay and/or bandwidth
2) Use an offset-list
Of delay and bandwidth, which is preferred to modify?
Delay is preferred, because other protocols also use the bandwidth command.
Does changing the delay or bandwidth impact a sending neighbor’s reported distance?
No
What are the two ways of matching all ip addresses with an off-set list?
Use any/any in the access-list, or reference access-list 0.
Does adding/removing an offset-list cause adjacencies to drop?
Yes
What does “sh ip eigrp topology” show by default? Give the command to see everything in the topology table.
It shows only successors and feasible successors.
sh ip eigrp topology all-links
What does an inbound versus an outbound offset-list do?
An inbound list changes the router’s local value plus the value it will report.
An outbound list changes only the reported value.
On the packet level, how is an offset-list implemented?
As delay
Can an offset-list decrease the value of the EIGRP metric?
No
What are the the conditions for choosing a feasible successor?
The feasible successor must have the same AD metric as the successor, and must satisfy the feasible condition. The feasibility condition states the feasible successor’s reported distance must be less than the successor’s feasible distance.
What does a Query include?
The query includes poisoned route information, including a maximum bandwidth and infinite delay.
What does a negative reply to a query include?
The reply includes a router-id with all zeros and a different value for the type of network. The delay is also maxxed out.
What is the active timer?
The active timer is the amount of time before a neighbor that doesn’t respond to a query is considered Stuck in Active and the adjacency is torn down.
What is the default active timer value?
The default active timer value is 3 minutes.
How much time must elapse before a SIA Query is sent to a non-responsive neighbor?
Half of the active timer value, so roughly 90 seconds by default.
What happens if a router receives an answer to a SIA Query?
If the neighbor sends back a SIA Reply, the active timer will be reset.
If a route is lost, what happens to it while the router goes through the Active route process?
The stale route remains in the routing table.
What are two ways to limit the scope of EIGRP active route queries?
Stub routers and router summarization
What is a stub router?
A stub router will not advertise learned routes amongst its neighbors by default. Other routers will also not send Query packets to it.
Give the command to change the default active timer to one minute.
router eigrp 100
timers active-time 1
By default, what will a stub router advertise?
It will advertise only connected and summary routes by default.
Give the command to set a router as a stub router that will advertise its redistributed routes as well as the default options.
router eigrp 100
eigrp stub connected summary redistributed
What options does an offset-list take for input?
Standard access-list only
What is the netmask for matching all bits?
255.255.255.255
What is the syntax to match all routes on a prefix-list?
0.0.0.0/0 le 32
What does variance enable?
Variance allows the installation of unequal cost routing paths into the routing table. By default, it is set to 1, meaning it only allows equal paths.
How is an extended ACL interpreted when used as a distribution list?
The source is evaluated as the sending neighbor IP address, and the destination is evaluated as the prefix in the update.
What is a distribute-list used for?
It can limit which routes are accepted and/or sent to neighbors.
When can a route be added as an unequal cost path to the routing table?
It must be a feasible successor route, and the reported distance must be less than the successor’s feasible distance multiplied by the variance.
FS’s RD greater than Successor’s FD * variance
What is the netmask octet for match?
255
What command will show any distribute-list filters that are impacting EIGRP?
sh ip protocols
What must the relationship of the ge or le number be to the CIDR notation number?
They cannot be lower or equal to the length on the CIDR notation.
Does adding a distribution list cause adjacencies to go down?
Yes
How does auto-summarization impact the number of queries?
The neighbors of the auto-summarization router will not query other neighbors if the route becomes unreachable. So, queries stop at one hop beyond the summarizing router(s).
Give the command to enable the maximum number of equal-cost paths that EIGRP can support.
router eigrp 100
maximum-paths 6
If no ge or le is specified, what value is used for the subnet mask?
The /# is used first for the number of interesting bits to match on, and then used again for matching the subnet mask.
What is the wildcard octet for ignore?
255
What is the wildcard mask for ignoring all bits?
255.255.255.255
Give the command to set variance to three.
router eigrp 10
variance 3
What happens if a distribute-list references a non-existent ACL?
It will have no impact.
What is the syntax to match a default route in a prefix-list?
0.0.0.0/0
Does ge or le come first in a prefix-list statement?
ge
What three options will the distribute-list command take as a source?
access-list, prefix-list, or route-map
What is the netmask octet for ignore?
0
What is the netmask for ignoring all bits?
0.0.0.0
Give the syntax for a prefix-list entry.
ip prefix-list MyList seq 10 …
What is the wildcard mask for matching all bits?
0.0.0.0
Give the prefix-list notation to deny all incoming prefixes that have the first three octets of 10.10.10.x and a subnet mask between 24 and 30.
ip prefix-list MyList seq 10 deny 10.10.10.0/24
ip prefix-list MyList seq 10 deny 10.10.10.0/24 ge 25 le 30
What additional functionality does a prefix-list add over an access-list?
The ability to match on the subnet mask as well as the prefix.
What is the wildcard octet for match?
0
Are prefix-list names case sensitive?
Yes
Give the command to apply a prefix-list for route filtering.
router eigrp 100
distribution-list prefix in/out
What impact will a route-map without a match statement have?
It will match everything.
Give the command to match an ACL within a route-map.
route-map Test permit 10
match ip address 101
What will the sequences numbers be for the following input?route-map INE permitroute-map INE deny
The permit will be overwritten, leaving only -
route-map Test deny 10
Give the command to match a prefix-list within a route-map.
route-map Test permit 10
match ip address prefix-list MyList
What direction to permits/denies work in a distribute-list?
Addresses must match the distribute list, or they are filtered.
Can a distribution list be entered without specifying direction?
No
Give the command to apply a route-map for route filtering.
router eigrp 100
distribute-list route-map INE in/out
Which EIGRP routers can perform summarization?
Any router
Where is EIGRP summarization configured?
On the interface
Give the command to summarize 10.0.0.0/8.
interface Serial0/0
ip summary-address eigrp 100 10.0.0.0 255.0.0.0
Which of the following results in dropping the adjacency: adding, removing, or changing a prefix-list?
All three
Can an interface have multiple summary addresses?
Yes
What side effect occurs as a result of adding a summary route?
The route will add the summary as a directly connected route to the network to its Null0 interface.
Are summary routes internal or external? What is the AD?
Internal; 90
What are three criteria for auto-summarization to occur?
- The network must be local to the router.
- The network must be defined with “network …” rather than redistributed.
- The sending interface must not be part of the summarized networks.
Give the command to show auto-summarizations in effect.
show ip protocols
Give the three ways to send a default route through EIGRP.
Redistribution of a static route, summarization, or configuration of a default classful network
What are two ways the default network can make it into the routing table through EIGRP?
There must be a static route with static redistribution, or the default network must already be an EIGRP-advertised route.
Give the command to set the default network.
ip default-network x.x.x.x
There is no mask since the network must be classful.
Give the command to summarize a default route.
interface Serial0/0
ip summary-address eigrp 0.0.0.0 0.0.0.0
What is a side effect of adding a summary-address statement on an interface?
No other routes will be advertised, except for other summary routes.
What is DUAL?
Diffusing Update ALgorithm
What kind of algorithm is EIGRP?
advanced distance vector
What address are EIGRP updates sent to?
In a multiaccess network, multicast address 224.0.0.10
In a point-to-point network, individual neighbor IP
What layer 4 protocol does EIGRP run on?
IP protocol 88
Name the five EIGRP packet types.
Hello, Query, Reply, Update, ACK
How queer Randy usually acts!
Which packets require an ACK?
Update, Query, and Reply
everything except Hello and ACK
What are RD and FD?
Reported distance (RD) is the neighbor’s metric for the route. Feasible distance (FD) is the advertised distance, plus the distance from this router to the neighbor.
How is EIGRP unlike other distance vector algorithms?
It only sends updates on change, and maintains relationships using hellos.
What does EIGRP use for metric calculation by default?
bandwidth and delay
What are the three steps to EIGRP neighbor convergence?
- Formation of neighbor relationship
- Exchange of routes to populate the topology table
- Run DUAL and populate the routing table
What is an AS?
An autonomous system is a collection of networks under one centralized administrative control entity.
What purpose do Hello packets serve?
They discover new neighbors and maintain existing relationships.
List the three classful network ranges.
Class A - anything before 127
Class B - anything after A and before 192
Class C - anything after B and before 224
What is the hold time, where is it advertised, and what value does it use by default?
The hold time is amount of time before a neighbor marks this router as dead. It is included in the Hello packet.
The default hold time is 3 x hello interval. On LAN links, this is 15 seconds. On T1 or slower, this is 180 seconds.
How are EIGRP routes indicated in the routing table?
D for interior routes and EX for exterior routes
List the process for forming a neighbor relationship.
- Both neighbors send unicast Hellos
- Each sends a unicast Update packet that is empty but has the Init flag set
- Each sends a unicast Update that contains the entire routing table
- Each neighbor ACKs the Updates.
What does a “retry limit exceeded” indicate?
This router is sending unicast Update packets with the initialization bit set in order to form an adjacency, but it is not receiving a response from the neighbor.
How are Hello and ACK packets related?
ACK packets are just Hello packets that are sent unicast and have a number in the acknowledge field.
What is the side effect of adding a static neighbor?
Multicast is disabled on that interface.
Name five requirements for forming a neighbor adjacency.
The interfaces must be able to reach each other.
The interfaces must not be in passive mode.
Authentication must match.
K-values must match.
AS must match.
In an interface with a primary and secondary ip address, which address(es) will EIGRP communication originate from?
primary IP only
What does this error message indicate?
“Neighbor is blocked: not on common subnet”
The router is receiving packets from an address on a subnet that it does not have directly connected on that interface.
What is the error message for mismatched AS values?
There is no error. It fails silently.
What is the command to set non-standard K-values?
router eigrp 100
metric weights k1 k2 k3 k4 k5
How often are Hello packets sent by default?
5 seconds on a LAN or 60 seconds on a T1 or slower
What is the command to change how often hello packets are sent?
interface Gigabit0/0
ip hello-interval eigrp #
What are the default hold timers?
Three times the hello time by default.
15 seconds on a LAN and 180 seconds on a T1 or slower
What is the command to set the hold timer?
interface Gigabit0/0
ip hold-timer eigrp #
What impact does updating the hold-timer on an interface have?
The router will send a different dead timer in its Hello packets, and its neighbor will wait that many seconds before marking it down.
What command will show non-default hello intervals (and hold timers on newer versions of IOS)?
sh ip eigrp interface detail
What kinds of authentication does EIGRP support?
MD5 only
Give the commands to create a keychain called MyKeys with a password of supersecret.
key chain MyKeys
key 1
key-string supersecret
Give the commands to apply the keychain called MyKeys to interface GigabitEthernet0/0
interface GigabitEthernet0/0
ip authentication mode eigrp md5
ip authentication key-chain eigrp MyKeys
Which parts of authentication have to match to form a neighbor relationship?
The key number and key-string.
The key chain name does not have to match.
Give the command to disable split-horizon.
interface Gigabit0/0
no ip split-horizon eigrp
How will a router respond to a Query for a network it has never seen?
It will reply back in the negative.
How will a router respond to a Query that it has an alternate route to?
The router will reply with the alternative route.
How will a router respond to a Query for a network that previously existed through the querying router?
It will propagate the query.