CCNP Command Practice 2 Flashcards

1
Q

Configure EIGRP

Is the wildcard mask required? If not, what happens?

A

(config)# router eigrp {asn}
(config-router)# network {ip address} {mask}

Wildcard mask is not required. If no wildcard mask is specified the network is summarized to the nearest major network boundary.

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
2
Q

Displays changes with EIGRP neighbors

A

(config-router)# log-neighbor-changes

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
3
Q

Configure EIGRP bandwidth

A

(config-if)# bandwidth x

Measured in kilobits

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
4
Q

Enable or disable EIGRP auto-summary

A

(config-router)# auto-summary

no auto-summary

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
5
Q

Configure EIGRP manual summarization

A

(config)# interface

(config-if)# ip summary-address eigrp {asn} {ip address} {mask} {admin distance}

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
6
Q

Configure an EIGRP passive interface

Configure all interfaces as passive

A

(config)# router eigrp
(config-router)# network {ip address}
(config-router)# passive-interface [default/interface]

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
7
Q

Create a pseudo passive EIGRP interface

A

(config)# router eigrp
(config-router)# network
(config-router)# distribute-list {#/prefix/route-map} out {interface}

(config)# access-list {#} deny any

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
8
Q

Inject default route into EIGRP using a static route

A

(config)# ip route 0.0.0.0 0.0.0.0
(config)# router eigrp {asn}
(config-router)# redistribute static

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
9
Q

Inject a default route into EIGRP using the IP default network command

A

(config)# router eigrp {asn}
(config-router)# network {ip address}

(config) #ip route 0.0.0.0 0.0.0.0 {next hop}
(config) #ip default-network {network address}

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
10
Q

Inject a default route inte EIGRP by summarizing to 0.0.0.0/0

A

(config)# router eigrp {asn}
(config-router)# network {ip address}

(config-if)# ip address {ip address} {mask}
(config-if)# ip summary-address eigrp 0.0.0.0 0.0.0.0 {asn} 0.0.0.0 0.0.0.0 [admin distance]

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
11
Q

Accept default routing information into EIGRP

A

(config)# router eigrp {asn}
(config-router)# default-information in

Note: add no to not accept default information

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
12
Q

Change maximum paths EIGRP

A

(config)# router eigrp {asn}

(config-router)#maximum-paths {paths}

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
13
Q

Change the EIGRP variance

A

(config)# router eigrp {asn}

(config-router)# variance n

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
14
Q

Configure EIGRP bandwidth use

A

(config)# interface {interface}
(config-if)# bandwidth x
(config-if)# ip bandwidth-percent eigrp {asn} {percent}

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
15
Q

Configure EIGRP authentication

A

(config)# key chain {name}
(config-keychain)# key {number}
(config-keychain-key)# key-string {string}
(config-keychain-key)#accept-lifetime xxxxxxx
(config-keychain-key)#send-lifetime start-time xxxx
(config-keychain-key)accept-lifetime start-time xxxx

(config)#interface {interface}
(config-if)# ip authentication mode eigrp {asn} md5
(config-if)# ip authentication key-chain eigrp {asn} {name}

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
16
Q

Configure an EIGRP stub network

What are the options?

Which are enabled by default?

A

(config) # router eigrp {asn}
(config) # eigrp stub

Connected, static, summary, and receive-only.

Connected and summary are enabled by default

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
17
Q

Manually configure EIGRP neighbor

Will communication be sent unicast or multicast?

A

(config)# router eigrp {asn}
(config-router)# network {network}
(config-router)# neighbor {ip address}

unicast

Warning: This disables multicast on the interface

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
18
Q

Configure EIGRP over frame-relay dynamic mappings

A

(config)# interface {interface}
(config-if)# ip address {ip address} {mask}
(config-if)# encapsulation frame-relay

(config)# router eigrp {asn}
(config-router)# network {ip address}

Note: Split horizon is disabled by default on the physical interface

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
19
Q

Configure EIGRP over frame relay with static mappings

A

(config)# interface {interface}
(config-if)# ip address {ip address} {mask}
(config-if)# encapsulation frame-relay
(config-if)# frame-relay map ip {ip address} {dlci} [broadcast]

(config)# router eigrp {asn}
(config-router)# network {ip address}

Make sure to include the broadcast keyword to allow broadcasts to be forwarded on the interface! Not needed when mapping the local DLCI to local IP!

20
Q

EIGRP over frame relay using multipoint subinterfaces

A

(config)# interface {interface}
(config-if)# no ip address
(config-if)# no frame-relay inverse-arp eigrp {asn}

(config)interface {interface}.1 multipoint
(config-subif) ip address {ip address} {mask}
(config-subif)# no ip split-horizon eigrp {asn}
(config-subif)# frame-relay map ip {ip address} {dlci} [broadcast]

(config)# router eigrp {asn}
(config-router)# network {ip address}

Make sure to include the broadcast keyword to allow broadcasts to be forwarded on the interface! Not needed when mapping the local DLCI to local IP!

21
Q

EIGRP over frame relay with point-to-point subinterfaces

A

(config)# interface
(config-if)#no ip address
(config-if)#encapsulation frame-relay

(config)# interface {interface}.1 point-to-point
(config-if)#ip address {ip address}
(config-if)#frame-relay interface-dlci {dlci}

22
Q

Configure OSPF

A

(config)# router ospf {PID}
(config-router)# network {ip address} area {area}
(config-router)#log-adjacency-changes detail

23
Q

Configure OSPF router ID and DR/BDR priority

What does a priority of 0 do?

A

(config)# router ospf {PID}
(config-router)# router-id {router-id}
(config-router)# ip ospf priority {priority}

Priority 0 makes a router ineligable to become either the BDR or the DR

24
Q

Configure an OSPF interface as passive

A

(config)# router ospf {PID}
(config-router)# network {ip address}
(config-router)# passive-interface {interface/default}

25
Q

Modify the OSPF cost

A

(config)#interface {interface}
(config-if)# ip address {ip address} {mask}
(config-if)# ip ospf cost {cost}

26
Q

OSPF auto-cost reference bandwidth

A

(config)# router ospf 1
(config-router)# auto-cost reference-bandwidth 1000

Note: Units are in Mbps

27
Q

OSPF authentication using MD5

A

(config)# router ospf
(config-router)# area {area} authentication message-digest

(config) # interface {interface}
(config) # ip ospf message-digest-key {key} md5 {password}

Note: Both key number and password must match that of the neighboring router.

28
Q

Propogate default route using OSPF

A

(config)# ip route 0.0.0.0 0.0.0.0 {interface}
(config)# router ospf {PID}
(config-router)# default-information originate [always]

The always option will cause the route to propogate a default route even if one is not configured on the router

29
Q

Configure an OSPF stub or totally stubby area

A

(config)# router ospf {PID}
(config-router)# network {ip address}
(config-router)# area {area} stub [no-summary]

30
Q

Configure OSPF not-so-stubby area (NSSA)

A

(config)# router ospf {PID}
(config-router)# network {ip address}
(config-router)# area {area} nssa [no-summary]

31
Q

Configure OSPF inter-area route summarization

Configure OSPF external route summarization (on asbr)

A

(config)# router ospf {PID}
(config-router)# area {area} range {network address} {mask}

(config-router)# summary-address {IP} {mask}

32
Q

Configure OSPF virtual link

A

(config)# router ospf {PID}
(config-router)# router id {RID}
(config-router)# network statements here
(config-router)# area {transit area} virtual link {opposite end rid}

Note: A virtual link has the following requirements:

It must be established between two routers that share a common area and are both ABRs.

One of these two routers must be connected to the backbone.

A virtual link cannot be configured through stub areas.

33
Q

OSPF full mesh frame relay - NBMA on physical interfaces

A

(config)# router ospf {PID}
(config-router)# network {IP} area {area}
(config-router)# neighbor {IP}

(config)# interface {interface}
(config-if)# encapsulation frame-relay
(config-if)# ip address {IP} {mask}
(config-if)# ip ospf network non-broadcast
(config-if)# frame-relay map ip {IP} {dlci}

34
Q

OSPF full-mesh frame relay broadcast on physical interface

A
(config)# interface 
(config-if)# encapsulation frame-relay
(config-if)# ip address {IP} {mask}
(config-if)# ip ospf network broadcast
(config-if)# ip ospf priority {priority}
(config-if)# frame-relay map ip  broadcast

(config)# router ospf {PID}
(config-router)# network {IP} area {area}

35
Q

Full-mesh Frame Relay: Point-to-Multipoint Networks

A

(config)# interface {interface}
(config-if)# encapsulation frame-relay
(config-if)# ip address {IP} {mask}
(config-if)# ip ospf network point-to-multipoint
(config)# router ospf {PID}
(config-router)# network {IP} area {area}

The optional non-broadcast command is a cisco extension toth eRFC compliant ponit to multipoint mode.

Neighbors must be manually defined in non-broadcast mode.

DR/BDRs are not used in non-broadcast mode

36
Q

Full-mesh frame relay: point-to-point networks with subinterfaces

A

(config)# interface {interface}
(config-if)# encapsulation frame-relay

(config)# interface {interface}.x point-to-point
(config-if)# ip address
(config-if)# frame-relay interface-dlci {dlci}

37
Q

Route filtering using the distribute list command for filtering routes on an interface, in and out, globally, in and out.

A

(config)# router
(config-router)# distribute list in
(config-router)# distribute list out
(config-router)# distribute list

38
Q

Configure generic BGP

A

(config)#router bgp {PID} Note: Only one BGP process may run at a time
(config-router)# network {network} mask {mask}
(config-router)# neighbor {neighbor IP} remote-as {remote-as}

BGP will only advertise networks with an exact match to the network statement. You can advertise a static route with a null destination.

39
Q

Configure BGP with a loopback address

A

(config)# router bgp {PID}

(config-router)# neighbor {neighbor ip} update-source {interface}

40
Q

Configure eBGP multihop

A

(config)# router bgp {PID}
(config-router{# neighbor {IP address} remote-as {remote-as}
(config-router)# neighbor {ip address} ebgp-multihop {#}

41
Q

Create a distribute list outboundthat references a prefix list

A

(config)#router {protocol}
(config-router)# distribute-list prefix {name} out {interface}
(config)# ip prefix-list {name} seq {seq} deny {ip address}

42
Q

Use a distribute list that references a route map

A

(config)# router {protocol}
(config-router)# distribute-list route-map {prefix-list} out

(config)# route-map {prefix-list} deny {seq #}
(config-route-map)# match ip address prefix-list {prefix-list}
(config)#route-map {prefix-list} permit {seq #}

(config)#ip prefix-list {name} {conditions}

43
Q

Create a default route in BGP

A

(config)# router bgp {asn}

44
Q

Configure IPv6 EIGRP

A

(config)# ipv6 unicast-routing
(config)# ipv6 router eigrp {ASN}
(config-router)# router-id {ipv4-address}
(config-router)# no shut

(config)# interface {interface}
(config-if)# ipv6 eigrp {ASN}

45
Q

Configure MP-BGP

A

(config)# ipv6 unicast-routing
(config)# router bgp {asn}
(config-router)# router-id {ip address}
(config-router)# neighbor {ipv6 address} remote-as {asn}
(config-router)# address-family ipv6 unicast
(config-router-af)# neighbor {ipv6 address} activate
(config-router-aff)# network {ipv6 address}

46
Q

Configure OSPFv3

A
To Configure OSPFv3:
R2(config)# ipv6 unicast-routing
!
R2(config)# ipv6 router ospf 100
R2(config-rtr)# router-id 10.10.10.1
R2(config-rtr)# area 1 stub no-summary
R2(config-rtr)# exit
!
R2(config)# interface gig1/1
R2(config-if)# ipv6 address 2003:2:1:2::1/64
R2(config-if)# ipv6 ospf 100 area 0
!
R2(config)# interface gig1/2
R2(config-if)# ipv6 address 2003:2:1:A::1/64
R2(config-if)# ipv6 ospf 100 area 1
R2(config-if)# ipv6 ospf priority 30