Config Commands Flashcards

1
Q

Configure device system name

A

config t

hostname hostname

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
2
Q

Set the encrypted enable password

A

config t

enable secret password

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
3
Q

Set an unencrypted enable password

A

enable password password

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
4
Q

Enable password encryption on all clear text passwords within config file

A

config t

service password-encryption

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
5
Q

Assign IP address to a VLAN

A

config t

int vlan [vlan number]

ip address [ip address] [subnet mask]

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
6
Q

Assign default gateway

A

config t

ip default-gateway [ip address]

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
7
Q

Set interface description

A

config t

int [interface number]

description description

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
8
Q

Add and name a vlan

A

config t

vlan [vlan number]

name [vlan name]

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
9
Q

Configure speed

A

config t

int [interface number]

speed [10, 100, 1000, auto]

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
10
Q

Configure duplex setting

A

config t

int [interface number]

duplex [auto, full, half]

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
11
Q

Assign interface to a VLAN

A

config t

int [interface]

switchport mode access vlan [vlan number]

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
12
Q

Enable Port Security

A

config t

int [interface]

switchport mode access

switchport port-security mac-address sticky

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
13
Q

Configure Telenet sessions with password

A

config t

line vty [first line] [last line]

login

password [password]

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
14
Q

Synchronize console messages

A

logging synchronous

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
15
Q

Set timezone and automatically adjust

A

config t

clock timezone [timezone] [hours offset from gmt]

clock summer-time [timezone] recurring

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
16
Q

Set the switch priority for vlan

A

config t

spanning-tree vlan [vlan number] priority [priority number]

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
17
Q

Enable portfast

A

config t

int [interface number]

spanning-tree portfast

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
18
Q

Enable RSTP/PVST

A

config t

spanning-tree mode [rapid-pvst, pvst]

19
Q

Creat vlan

A

config t

vlan [vlan number]

name [vlan name]

20
Q

Force interface into trunk

A

config t

int [interface]

switchport mode trunk

21
Q

Assign switch to VTP domain

A

config t

vtp domain [domain name]

22
Q

Change VTP mode to client

A

config t

vtp mode client

23
Q

Enable http server to SDM can be used

A

config t

ip http server

24
Q

Define username and password for protocols on router/switch

A

config t

username [username] password [password]

25
Q

Disable DNS lookup

A

config t

no ip domain-lookup

26
Q

Set logical bandwidth of interface

A

config t

int [interface]

bandwidth [bandwidth]

(used by routing protocols, SNMP, queuing, etc)

27
Q

Set physical clock

A

config t

int [interface]

clock rate 64000

28
Q

Set the serial interface WAN encapsulation

A

config t

int s[serial interface]

encapsulation [frame-relay, hdlc, ppp]

29
Q

Add authentication on PPP

A

config t

int s[interface number]

encapsulation ppp

ppp authentication [pap, chap]

30
Q

Add static route

A

config t

ip route [network/host address] [mask] [address/interface to exit] [OPTIONAL* adminstrative distance number (default is 1)]

31
Q

Enable RIP v1 on all local interfaces

A

config t

router rip

network [network ip address]

32
Q

Enable RIP v2

A

config t

router rip

network [network ip]

version 2

33
Q

Enable router as DHCP service

A

config t

ip dhcp pool [name of pool]

network [network ip] [mask]

default-router [default router IP]

exit

ip dhcp exlcuded-address [ip addys to exclue] [mask]

34
Q

Create logical subinterface for 802.1q trunking

A

config t

int [interface address.subinterface]

encapulation dot1q [vlan id]

ip address [vlan ip default ip] [vlan mask]

35
Q

Enable OSPF

A

config t

router ospf [ospf instance number]

network [network ip] [wildcard mask] area [area number]

36
Q

Configure EIGRP

A

config t

router eigrp [ASN number]

network [network ip] OR

network [network ip] [wildcard mask]

37
Q

Define Standard ACL

A

config t

access-list [number of access list] [permit, deny] [ip to permit/deny]

38
Q

Define Extended ACL

A

access-list [access list number 100-199] [permit/deny] [eigrp, icmp, ip, osfp, tcp udp] [source address, any, host host ip] [destination ip address, any, host host ip] eq [ftp, smtp, telnet, www]

39
Q

Attach ACL to interface

A

config t

int [interface]

ip access-group [access list] [in, out]

40
Q

Config static NAT

A

ip nat [inside, outside] source static [inside local IP] interface [interface id to exit]

41
Q

Define interface which NAT takes place on

A

config t

int [interface]

ip nat [inside, outside]

42
Q

Enable RIPng

A

config t

ipv6 unicast-routing

ipv6 router rip ccna

interface [interface number]

ipv6 rip ccna enable

43
Q
A