CCNP Route Flashcards
List IPv4 Header Fields and their width in bits
Version (4) Header Length (4) Type of Service (8) Total Length (16) Identification (16) IP Flags (3) Fragment Offset (13) Time to Live (8) Protocol (8) Header Checksum (16) Source Address (32) Destination Address (32) IP Option (variable)
What is the IPv4 Identification field?
If the packet is fragmented this field will identify which packet the fragments belong to.
What is the IPv4 IP Flags field?
3 bits
1 - reserved (0)
2 - DF (Don’t Fragment)
3 - MF (More Fragments) - set on all fragmented packets except the last one.
How do IPv4 fragments get put back together?
- MF bit set to 1 on all except the last packet
- Fragment Offset dictates the order
- Identification field dictates which packet the fragments belong to
List common IPv4 protocol numbers
1 - ICMP 2 - IGMP 6 - TCP 17 - UDP 47 - GRE 50 - ESP 51 - AH 88 - EIGRP 89 - OSPF
Describe ARP request and reply. What are the source/destination MAC addresses and source/destination IP addresses.
ARP request - source MAC of requester, broadcast MAC (00:00:00:00:00:00:00) for destination, source IP of requester, destination IP of replier
ARP reply - source MAC of replier, destination MAC of requester, source IP of replier, destination IP of requester
Configure a DHCP server for the 192.168.12.0/24 network which excludes IP 192.168.12.100 and sets the gateway to 192.168.15.1, DNS to 8.8.8.8, and points IP phones to a TFTP server at 92.168.12.200.
hostname DHCP ! interface FastEthernet0/0 ip address 192.168.12.1 255.255.255.0 ! ip dhcp excluded-address 192.168.12.100 ! ip dhcp pool MYPOOL network 192.168.12.0 255.255.255.0 default-router 192.168.12.1 dns-server 8.8.8.8 option 150 ip 192.168.12.200 !
Describe what happens when a DHCP discover packet is relayed.
What is the source and destination IP of the relayed packet?
- The broadcast packet is re-encapsulated sent as a unicast packet to the server.
- When it is sent a field called giaddr (Gateway Address) is added. It adds the IP of the interface on which the DHCP packet was received into this field.
The source is the interface IP and the destination is the IP of the DHCP server.
What show command will let one see if a DHCP relay is configured
‘show ip interface’
Output will have:
Helper address is x.x.x.x
List fields and lengths of UDP header
source port (16) destination port (16) UDP length (16) UDP checksum (16)
List basic UDP bullet points
It operates on the transport layer of the OSI model.
Is a connectionless protocol, does not setup a connection…just sends data.
Limited error correction because we have a checksum.
Best-effort or unreliable protocol.
No data-recovery features.
List TCP header fields in order
Source port (16) Destination port (16) Sequence (32) Acknowledgement (32) Data Offset (4) Reserved (6) Flags (6) Window (16) Checksum (16) Urgent Pointer (16)
Describe the TCP sequence number field and its use.
- 32 bit
- random initial value
- receiver sends back ack based on this value (
Describe the TCP acknowledgement number and its use
- the receiver requests the next segment by increment the last received sequence number by 1 and placing it in this field
Data Offset
Length of TCP header
What is RSV field in TCP used for
Nothing - always set to 0
List TCP flags
URG - urgent pointer ACK - PSH - Tells application to transmit data immediately and don't fill entire segment RST - Used to reset the connection SYN - Used for 3 way handshake FIN - Used for normal end of session
What is the TCP window field and what is it used for?
- 16 bit
- Specifies number of bytes receiver is willing to receive.
What is the urgent pointer field in TCP?
When the URG bit has been set the urgent pointer indicates where the urgent data ends.
How do you calculate the bandwidth delay product?
bandwidth (bits per sec) x round trip time (in seconds)
List basic ICMP header fields
Type (8)
Code (8)
Checksum (16)
List major ICMPv4 type values
0 - echo reply 3 - destination unreachable 5 - redirect 8 - echo 11 - time exceeded 13 - Timestamp 14 - Timestamp reply
List common codes for ICMP destination unreachable
0 - net unreachable 1 - host unreachable 2 - protocol unreachable 3 - port unreachable 4 - fragmentation needed and df set 5 - source route failed 6 - destination network unknown 7 - destination host unknown 8 - source host isolated 9 - communication with destination network is administratively prohibited 10 - communication with destination net is administratively prohibited 13 - Communication administratively prohibited
List 3 problems that may be experienced if routing is asymmetric
- NAT failures
- Stateful inspection failures
- Unicast flooding
What is unicast flooding
This happens when a switch unintentionally floods unicast packets. If routing is asymmetric the switch on the return path may not learn the MAC address from the transmitting host.
What is needed to become an EIGRP feasible successor
- Must not be the successor
- The advertised distance < feasible distance of successor
How does one configure EIGRP unequal cost load balancing?
router mode:
variance <i>multiplier</i>
What protocol does EIGRP use for communication?
RTP (Reliable Transport Protocol) - IP protocol number 88
How are EIGRP hello packets sent on a multi-access network?
Multicast to 224.0.0.10
List EIGRP packet types
Hello Update Query Reply ACK
What are the administrative distances of the major routing protocols?
Directly connected: 0 Static: 1 EIGRP Summary 5 EBGP 20 EIGRP 90 IGRP 100 OSPF 110 IS-IS 115 RIP 120 EGP 140 ODR 160 EX EIGRP 170 iBGP 200 NHRP 250 Floating Static (ex. DHCP-learned) 254 Unknown 255
What is the command to view the EIGRP neighbor table and what information is contained in it?
show ip eigrp neighbors
Lists all directly connected neighbors
- H (Handle) - first neighbor gets 0 - next one 1 - gaps get filled
- Next Hop IP
- Interface
- Hold Time
- Uptime
- SRTT (Smooth round trip time)
- RTO (retransmission timeout)
- Q Count
- Seq Number
List codes in EIGRP topology table
P - Passive A - Active U - Update Q - Query R - Reply r - reply Status s - sia Status
When troubleshooting EIGRP what command shows active routes?
show ip eigrp topology active
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status
A 10.100.1.1/32, 1 successors, FD is Inaccessible
1 replies, active 00:00:56, query-origin: Successor Origin
via 10.2.1.2 (Infinity/Infinity), Ethernet1/0
via 172.16.1.5 (Infinity/Infinity), r, Serial2/0, serno 562
via 10.2.1.3 (Infinity/Infinity), Ethernet1/0, serno 560
How to view traffic share on unequally load balanced EIGRP routes.
Traffic share count is in output of ‘show ip route <i>x.x.x.x</i>
List EIGRP K values
Bandwidth (K1) Load (K2) Delay (K3) Reliability (K4) MTU (K5)
What is the formula for an EIGRP metric with default K values?
Metric = (10^7 / minimum bandwidth) * 256 + (sum of delays) * 256
What command sets the EIGRP metric to use only delay in metric calculation
metric weights 0 0 0 1 0 0
What type of packet renews the EIGRP hold timer?
Any EIGRP packet - not just hello…
Summarize EIGRP routes
interface mode:
ip summary-address eigrp <i>as network subnet</i>
What is a discontiguous network?
A classful network split apart by a different network.
Configure MD5 authentication on an EIGRP interface
hostname R1 ! interface fastEthernet 0/0 ip address 192.168.12.1 255.255.255.0 ip authentication mode eigrp 12 md5 ip authentication key-chain eigrp 12 MY_KEY_CHAIN ! router eigrp 12 network 192.168.12.0 ! key chain MY_KEY_CHAIN key 1 key-string MY_KEY_STRING
What are the 2 recommended methods for advertising EIGRP default routes
1) redistribute static default route
2) ip summary-address command
Configure eigrp hello and hold time
interface:
ip hold-time eigrp <i>as seconds</i>
ip hello-interval eigrp <i>as seconds</i>
Configure EIGRP summary address
ip summary-address eigrp <i>as network mask</i>
By default what routes does an EIGRP stub router advertise to backbone routers?
connected and summary routes
Configure a router as an EIGRP stub router
router mode:
eigrp stub
When configuring eigrp stub what are the options for routes advertised by the stub?
receive-only
connected
static
summary
redistribute
What configuration is needed to have an eigrp stub router advertise static routes?
global: ip route 1.0.0.0 255.0.0.0 1.2.1.1 router mode: eigrp stub static redistribute static
EIGRP: filter inbound routes on FastEthernet0/0 so that 172.16.1.0/24 is not learned on that interface
hostname R1 ! interface FastEthernet0/0 ip address 192.168.12.1 255.255.255.0 ! router eigrp 12 distribute-list 1 in FastEthernet0/0 network 192.168.12.0 ! access-list 1 deny 172.16.1.0 0.0.0.255 access-list 1 permit any
Use prefix list - allow /28 or larger subnets under 10.10.0.0/16 - distribute in fa0/0 eigrp 12
router eigrp 12
distribute-list prefix BRANCHES in FastEthernet0/0
!
ip prefix-list BRANCHES seq 5 permit 10.10.0.0/16 le 28
Configure outbound EIGRP route map that filters out 192.168.1.0/24 using an ACL and any prefix under 172.16.0.0/20 with mask /26 or longer using a prefixlit
router eigrp 1 distribute-list route-map FILTER_OUT out ! ip access-list standard NET_192 permit 192.168.1.0 0.0.0.255 ! ip prefix-list SMALL_PREFIXES seq 5 permit 172.16.0.0/20 ge 26 ! route-map FILTER_OUT deny 10 match ip address NET_192 ! route-map FILTER_OUT deny 20 match ip address prefix-list SMALL_PREFIXES ! route-map FILTER_OUT permit 30
What command shows frame relay DLCI mapping?
show frame-relay map
What commands shows if a PVC is active?
show frame-relay pvc
If not using sub-interfaces what two things are needed to enable spoke-to-spoke communication with EIGRP
interface configuration mode:
no ip split-horizon eigrp <i>as</i>
frame-relay map ip <i>spoke-ip hub-dlci</i>
Configure frame-relay point-to-point subinterfaces
interface Serial 0/0.12 point-to-point ip address 192.168.12.1 255.255.255.0 frame-relay interface-dlci 102 ! interface Serial 0/0.13 point-to-point ip address 192.168.13.1 255.255.255.0 frame-relay interface-dlci 103
How does the eigrp ip bandwidth-percent command on a multipoint network.
It takes the bandwidth defined on the interface and divides it by the number of neighbors. The percentage is then applied to the result to determine the maximum bandwidth for all neighbors.
So that the eigrp ip bandwidth-percent command works properly what is the appropriate bandwidth setting on a multipoint interface?
The bandwidth of the smallest PVC multiplied by the number of links.
GIven a scenario in which there are 10 sub-interfaces with 64k CIRs and a 256k physical interface that already has the correct bandwidth statement what is the eigrp ip bandwidth-percent statement that should go on each subinterface to allow eigrp to use approximately 32k.
ip bandwidth-percent eigrp 1 128
256 / 10 = 25
25 * 1.28 = 32
Will two routers with the same EIGRP router ID form a neighbor adjacency?
Yes
In what case will the EIGRP router ID need to be different.
If a router receives an external route from a neighbor that has the same router id it won’t accept it.
If an EIGRP external route is dropped due to it being learned from a router with the same router-id what command will you see that happening in.
show ip eigrp events
Configure EIGRP in named mode for AS 12 using MY_CHAIN for authentication.
router eigrp MY_NAME ! address-family ipv4 unicast autonomous-system 12 ! af-interface GigabitEthernet0/0 authentication mode md5 authentication key-chain MY_CHAIN exit-af-interface ! topology base exit-af-topology network 192.168.12.0 exit-address-family
List fields in an OSPF hello packet
Router ID Hello/Dead Interval Neighbors Area ID Router Priority DR and BDR IP address Authentication password Stub area flag
How many equal cost paths in OSPF
4 in routing table 16 max (in topology?)
OSPF - what is checked before adding LSA information to LSDB? In what cases is it not added and what happens?
If entry is not in LSDB it is added.
If it is already in the LSDB and the sequence number is the same it is ignored. If the sequence number is higher it is also added. If the sequence number is lower then an LSU is sent to the source with the newer information.
OSPF - what happens when an LSA is added to the LSDB?
The router sends an LSAck, floods the LSA, and runs SPF.
How long is an OSPF LSA valid for?
30 minutes by default
What happens when an OSPF LSA expires?
The router that sends it will send a new one with a higher sequence number. If it isn’t replaced a router will delete the LSA when the timer expires.
Is anything else checked besides sequence number to determine if an LSA is more recent?
LSA is added if it has
1) a higher sequence number
2) a higher checksum
3) an age equal to the maximum age
4) if the link-state age is much younger
How can one check the sequence number on OSPF LSAs?
show ip ospf database
Configure ospf plain-text authentication
interface configuration mode:
ip ospf authentication
ip ospf authentication-key MYPASS
Alternatively enable authentication on area - just must still set key on interface:
router ospf 1
area 0 authentication
Commands needed for ospf md5 authentication
interface FastEthernet0/0 ip ospf message-digest-key 1 md5 MYPASS ip ospf authentication message-digest ! (instead of ip ospf message-digest-key on interface) router ospf 1 area 0 authentication message-digest
List all LSA types
LSA Type 1: Router LSA
LSA Type 2: Network LSA
LSA Type 3: Summary LSA
LSA Type 4: Summary ASBR LSA
LSA Type 5: Autonomous system external LSA
LSA Type 7: Not-so-stubby area (External) LSA
LSA Type 8: External attribute LSA for BGP
What basic information is in an OSPF router LSA?
IP prefix on interface
For each link:
Link type
Link ID
What are the 4 link types for OSPF LSAs and what is the link id for each?
1, Point-to-point connection to another router, Neighbor router ID
2, Connection to transit network, IP address of DR
3, Connection to stub network, IP Network
4, Virtual Link, Neighbor router ID
When are OSPF type 2 LSAs generated?
By a DR on a multi-access network.
On type 4 and 5 LSAs how is auto-summarization performed.
It isn’t.
Type 4 is to find the ASBR
Type 5 is the prefix
How is the OSPF router-id selected? How can it be statically defined?
Manual configuration of the router ID.
Highest IP address on a loopback interface.
Highest IP address on a non-loopback interface.
R1(config)#router ospf 1
R1(config-router)#router-id 111.111.111.111
Where does one configure a passive interface for OSPF?
Router configuration mode.
Configure an ospf priority that will give priority over a Cisco router with default priority.
interface fastEthernet0/0
ip ospf priority 2
If you set the OSPF priority to be highest on the segment what routers need their OSPF processes cleared in order to get it to take effect?
The DR and BDR are the only 2 routers that need to be cleared with clear ip ospf process.
If OSPF priority is the same which router becomes DR in multi-access segment?
Highest router-id
What is the command to set the ospf reference bandwidth to 1 Gbps?
Router(config-router)#auto-cost reference-bandwidth 1000
What is the command to get OSPF to advertise a default route?
router mode:
default-information originate (always)
Without always keyword it will only be originated if there is a default route already in the routing table on that router.
What are the basic things to configure for an OSPF NBMA network?
interface config
ip ospf non-broadcast
ip ospf priority 0 (on spokes)
ip ospf priority 1 (on hub)
On hub: router mode: neighbor spoke 1 neighbor spoke 2 ... etc ...