6. Internetworking Operating System (IOS) Flashcards
Who created IOS and when?
William Yeager in 1985
What common things is IOS responsible for?
- Carrying out network protocols and functions
- Connecting high speed traffic between devices
- Adding security to control access and stopping unauthorised network use
- Supplying network reliability for connecting to network resources
What ways can you access the IOS on a router or switch?
- Console port (RJ-45, USB)
- Modem into the auxiliary (aux) port (only on a router)
- Telnet and SSH session
Access to the IOS command line is called an EXEC session
Which connection methods are considered out-of-band?
- Console
- Auxiliary (via modem connection)
The auxiliary connection allows you to remotely configure the router even if it’s down
Which connection methods are considered in band?
- Telnet and SSH (via the network hence ‘in band’)
What will a switch or router do upon power up?
- Perform a power on self test (POST)
- Load the Cisco IOS from flash memory into RAM (if an IOS file is present)
- Locate and load into RAM the startup-config file (stored in NVRAM)
- If no valid startup-config is found, the switch/router enters setup mode.
You can exit set up mode at any time by pressing?
Ctrl + C
Identify the different command prompt types and they uses?
switch>
switch#
switch(config)#
switch(config-line)#
switch(config-if)#
switch(config-router)#
switch(config-std-nacl)#
.
.
.
.
.
.
.
.
.
.
.
.
switch>
- user exec mode
- Mode first entered when session starts
- Limited to basic monitoring commands
switch>enable
switch#
- Privileged exec mode
- Provide access to all other router commands
switch#configure terminal
switch#config t
switch(config)#
- Global configuration mode
- Commands that affect the whole system
- Makes changes to running-config in RAM
switch(config)#line console 0
switch(config-line)#
- Configuration of line inputs, ie console 0, vty 0 15 (telnet, SSH), aux
switch(config)#interface FastEthernet 0/0
switch(config)#int fa0/0
switch(config-if)#
- Commands that affect interfaces/processes only
switch(config)#ip routing
switch(config)#router rip
switch(config-router)#
switch(config)#ip access-list standard username
switch(config-std-nacl)#
What command do you use to set the system clock?
switch#clock set 21:30:00 28 february 2025
What does % Incomplete command mean?
The command entered isn’t complete, ie missing inputs or options
What does % Invalid input detected at ‘^’ marker mean?
The command entered is incorrect at the given place ie an incorrect option was used, an option or command word is missing
What does % Ambiguous command: “command repeated” mean?
Example: switch#sh cl
There are multiple commands that begin with the string you entered and it’s not unique
Use switch#sh cl? to show the options
Enhanced editing commands
Ctrl+A
Ctrl+E
Esc+B
Ctrl+B
Ctrl+F
Esc+F
Ctrl+D
Backspace
Ctrl+R
Ctrl+U
Ctrl+W
Ctrl+Z
Tab
Ctrl+A - Move cursor to the beginning of the line
Ctrl+E - Move cursor to the end of the line
Esc+B - move back one word
Ctrl+B - move back one character
Ctrl+F - move forward one character
Esc+F - move forward one word
Ctrl+D - delete a single character
Backspace - delete a single character
Ctrl+R - redisplays a line
Ctrl+U - erases a line
Ctrl+W - erases a word
Ctrl+Z - end configuration mode and return to EXEC
Tab - finishes typing a command for you
What does the $ indicate on the command line?
The command line has automatically scrolled left (11 spaces) to display a long command
What does Ctrl+P do on the command line?
Shows the last command entered
Same as up arrow
What does Ctrl+N do on the command line?
Shows previous commands entered.
Same as down arrow
What does show history do on the command line?
Shows the last 20 commands entered
History buffer is 20 by default
What does show terminal do on the command line?
Shows the terminal configuration and history buffer size
What command can you use to change the history buffer size?
switch#terminal history size X
Max size is 255
What command would you use to set a new host name?
switch#config t
switch(config)#hostname alphaSwitch
alphaSwitch(config)#
Name the different types of banner you can create for the command line?
switch(config)#banner exec # message #
- Displayed at start of EXEC process
switch(config)#banner motd # message #
- Displayed whenever a connection is made to the device (telnet, aux, console)
switch(config)#banner login # message #
- Displayed after MOTD banner and before the user login prompts
switch(config)#banner prompt-timeout # message #
- Displayed when logging authentication times out
switch(config)#banner slip-ppp # message #
- Unsure when this is displayed
How do you set a user password on the command line?
switch(config)#enable password password
switch(config)#enable secret password
Enable secret is encrypted and overrides password if both are set
How do you set a console password on the command line?
switch(config)#line console 0
switch(config-line)#password password
switch(config-line)#login
Virtual terminal connections i.e. Telnet, SSH are similar except you enter the
switch(config)#line vty 0 15
configuration prompt
How do you change the console timeout?
switch(config-line)#exec-timeout *min sec
Default value is 10 minutes.
exec-timeout 0 0 means never time out
How can you stop annoying alert messages from appearing partway through entering commands?
switch(config-line)#logging synchronous
How do you resolve the error
switch#telnet router
Trying router (10.1.0.1)… Open
Password required, but none set
Connection to router closed by foreign host.
router(config-line)#line vty 0 15
router(config-line)#no login
Note, this is not recommended for a production environment!
What are the steps to setting up SSH?
- Set your house name
router(config)#hostname King - Set the domain name
router(config)#ip domain-name Nugget.com - Set the username to allow SSH client access.
router(config)#username lee password hello - Generate the encryption keys
router(config)#crypto key generate rsa - Enable SSH version 2
(not mandatory but strongly suggested)
router(config)#ip ssh version 2 - Connect to the VTY lines
router(config)#line vty 0 15 - Tell the lines to use the local database for password
router(config-line)#login local - Configure your access protocols
router(config-line)#transport input ssh telnet
The enable secret password is encrypted by default.
How can you manually configure a user mode and enable password for encryption?
To manually encrypt your password, you must use the password encryption service
switch(config)#service password-encryption
switch(config)#do show run
The passwords before enabling the password encryption service you must do a show running config to encrypt the password. If you set the password encryption service first and then enable your passwords they are automatically encrypted
How can you add information to an interface to help you navigate your network?
Add a description to your device interfaces using:
switch(config)#int fa0/0
switch(config-if)#description Lab VLAN Link
switch(config-if)#^Z
The description will then be visible in
show running-config
show interface
show interface description
Does the do command give?
The do command allows you to perform commands as if you were in user privilege mode
Commands like show and ping do not operate in global or specific configuration modes
What command can you use to show router and switch interfaces?
switch#show ip interface brief
switch#sh ip int brief
What commands can be used to configure an interface?
switch(config)#interface GigabitEthernet 0/1
switch(config)#int g0/1
switch(config-if)#speed 1000
switch(config-if)#duplex full
These commands shut off the auto detect mechanism on the port, forcing it to use these settings
How would you resolve the following message and ‘bring up’ an interface
router#sh int fa0/0
** fast ethernet 0/1 is administratively down, line protocol is down**
router(config-if)#no shutdown
How do you configure an IP address on an interface?
router(config)# int fa0/1
router(config-if)#ip address a.b.c.d xxx.xxx.xxx.xxx
You can use the secondary command to add an additional IP address
router(config-if)#ip address a.b.e.f xxx.xxx.xxx.xxx secondary
Note, having multiple IP addresses on an interface is not recommended
What options does the pipe | command give when manipulating displayed output?
- begin
- exclude
- include
- section
- redirect (to URL)
- tee (copy to URL)
switch#sh run | begin interface
router#sh ip route | include 192.168.10.5
When using a WAN or serial connection in a lab scenario, you may not have CSU/DSU equipment (channel service unit/data service unit)
In this scenario the device simulating the DCE (Data Communication Equipment) must provide the clock (not the DTE (data terminating equipment))
What commands can do this?
router(config)#int s0/0/0
router(config-if)#clock rate 1000000
Use show controllers s0/0/0 to confirm the settings
What command is used to save the configuration in RAM to NVRAM
switch#copy running-config start-config
switch#copy run start
switch#write (wr) can also be used
What command is used to delete/erase the start configuration?
switch#erase startup-config
startup-config must be used in full, no abbreviations
If the device is powered off and on, with no (startup) configuration in NVRAM, the router will offer setup mode
What command is used to reboot the device?
switch#reload
What is a loopback interface used for?
- The loop back interface is an internal interface that can be used for diagnostics.
- It is normally assigned the IP address 127.0.0.1, but can be given any IP and subnet mask
- It can be used as a source or destination address for commands like ping
When using a remote session, what command can you use to show debug output?
switch#terminal monitor
What command can be used to track the progress of a packet to a destination?
switch#traceroute
What command can you use to verify the configuration of an interface?
switch#show interface X
switch#sh int f0/0
What command can you use to clear the counters of an interface?
switch#clear counters fa0/0
What’s the difference between the
show interface and
show interfaces commands?
The show interface command shows information for a single specific interface, whereas show interfaces give statistics for all active interfaces
From the show interfaces output, what do the no buffer and ignored statistics mean?
x no buffer
This indicates the number of packets dropped because there is no buffer space left
x ignored
If the packet buffers are full packets will be dropped. Typically no buffer and ignored outputs increment together if you have some sort of broadcast storm, this can be caused by a bad NIC or bad network design.
From the show interfaces output, what are runt frames?
Frames that did not meet the minimum phrase size requirement of 55 bites.
This is typically caused by collisions
From the show interfaces output, what are giant frames?
Frames received that are larger than 1,518 bytes
From the show interfaces output, what do frame errors indicate?
This indicates frames received are of an illegal format or not complete.
This typically occurs after a collisions
From the show interfaces output, what do collisions and late collisions mean?
- Collisions These only occur when transmitting a frame in half duplex, the NIC listens on the receiving pair of the cable for another signal, if a signal is transmitted from another host, a collision has occurred
- Late Collisions All collisions should occur by the 55th bite of the frame, if a collision occurs after 55 bites the late collisions counter is incremented. This may indicate a duplex mismatched interface or if cable length exceeds specifications.
What information does the
show ip interface command provide?
The layer three configurations (all configured??) of the routers interface:
- IP address
- Subnet mask
- MTU (maximum transmission units) - - - Access list set status
- Helper address status
- Security level
etc
What information does the
show ip interface brief command provide?
This is a briefer version of show IP interface with IP address and status for each configured interface
What information does the
show protocols command provide?
This shows the status of layers 1 and 2 of each interface as well as the IP address used
What information does the
show controllers command provide?
This command displays information about the physical interface itself only.
This could include the type of serial cable plugged in, although this will only usually be a DTE cable that plugs into a type of DSU