LAB Config Cards Flashcards
Configure Router on a stick as follows:
Interface Gi0/0/0.
1) VLAN 1 = 10.1.1.0/24(native)., VLAN 10 = 10.1.10.0/24, VLAN 20 = 10.1.20.0/24
2) Router = last IP address in subnet.
#conf t #int gi0/0/0 #no shut #int gi0/0/0.1 #encapsulation dot1q 1 native #ip address 10.1.1.254 255.255.255.0 #int gi0/0/0.10 #encapsulation dot1q 10 #ip address 10.1.10.254 255.255.255.0 #int gi0/0/0.20 #encapsulation dot1q 20 #ip address 10.1.20.254 255.255.255.0
Configure switch for Router on a stick as follows:
1) Configure Vlan 1 (native) to have ip address 10.1.1.253/24
2) Configure uplink on switch Interface gi1/0/1 to form trunk relationship with router.
S1(config)# int vlan 1
S1(config-if)# no shut
S1(config-if)# ip address 10.1.1.253 255.255.255.0
S1(config)# int gi1/0/1
S1(config-if)# switchport trunk encapsulation dot1q
S1(config-if)# switchport mode trunk
Configure Switch for Router on a stick as follows:
1) Configure VLANs on switch (PC1 [gi1/0/2] in VLAN 10 and PC2 [gi1/0/3] in VLAN 20)
2) Assign links to PC’s to their respective vlan.
conf t
S1(config)#vlan 10
S1(config-vlan)#vlan 20
S1(config-vlan)#end
S1(config)#int gi1/0/2
S1(config-if)#switchport mode access
S1(config-if)#switch access vlan 10
S1(config-if)#int gi1/0/3
S1(config-if)#switchport mode access
S1(config-if)#switchport access vlan 20
Router on a stick:
What command would you use to verify config of the trunk port gi1/0/1 that connects to the router?
S1#sh int g1/0/1 switchport
Name: Gig1/0/1
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk private VLANs: none
Operational private-vlan: none
Trunking VLANs Enabled: All
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL
Protected: false
Appliance trust: none
Router on a stick:
What command would you use to verify config of the access port gi1/0/2 that connects to a device that is included in one of the vlans that are in the trunk?
What should the access and admin mode be?
S1#sh int g1/0/2 switchport
Name: Gig1/0/2
Switchport: Enabled
Administrative Mode: static access *** Answer
Operational Mode: static access *** Answer
Administrative Trunking Encapsulation: negotiated
Operational Trunking Encapsulation: native
Negotiation of Trunking: Off
Access Mode VLAN: 10 (PC1_gi1/0/2) *** Important Info.
Trunking Native Mode VLAN: 1 (default)*** Important Info.
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk encapsulation: dot1q *** Important Info.
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk private VLANs: none
Operational private-vlan: none
Trunking VLANs Enabled: All
Pruning VLANs Enabled: 2-1001 *** Important Info.
Capture Mode Disabled
Capture VLANs Allowed: ALL
Protected: false
Appliance trust: none
For the router on a stick how do you configure the switch with a default gateway when the routers ip address is 10.1.1.254?
S1(config)#ip default-gateway 10.1.1.254
First ensure that routing is disabled.
If this is a layer 2 switch ip routing will be enabled by default.
Run the following Command:
S1(config)#ip default-gateway 10.1.1.254
What command is used to change the native vlan on a switch?
switchport trunk native vlan 99
With OSPF if the MTU’s are mismatched what happens?
If the MTU’s on two routers are mismatched then ospf will be stuck in the Exstart, Exchange, or loading states.
What state does an OSPF neighbor begin in?
Down state - Hello Packets have not been exchanged.
What are the severity levels of Syslog messages?
0 - Emergency 1 - Alert 2 - Critical 3 - Errors 4 - Warnings 5 - Notifications 6 - Informational 7 - Debugging
What command do you use to stop debugging?
no debug all
What command would you use to show the config of a specific interface on a router?
sh run int g0/0/0
What command would you use to encrypt the enable password?
#conf t #service password-encryption
On a router how would you configure a secret password of “cisco123”?
#conf t #enable secret cisco123
Configure the first 5 telnet lines and use the line password of cisco on them.
Router1#conf t
Router1(config)#line vty 0 4
Router1(config-line)#password cisco
Router1(config-line)#login
Configure a console password of “cisco”
Router2(config-line)#line con 0
Router2(config-line)#password cisco
Router2(config-line)#login
Configure DHCP on Router1 as follows:
1) Excluded address range 10.1.1.1 to 10.1.1.100
2) Pool name = pc
3) Network 10.1.1.0/24
4) Default Gateway = Router 1 (int gi0/0/0 ip addy 10.1.1.254 DGW)
5) DNS Server = Router 1
6) Test that PC can ping loopback of Router 1
R1#conf t
R1(config)#ip dhcp excluded-address 10.1.1.1 10.1.1.100
R1(config)#ip dhcp pool pc
R1(dhcp-config)#network 10.1.1.0 255.255.255.0
R1(dhcp-config)#default-router 10.1.1.254
R1(dhcp-config)#dns-server 10.1.1.254
This command lists the addresses that the DHCP service on a router has assigned.
sh ip dhcp binding
example:
IP address Client-ID/ Lease expiration Type
Hardware address
10.1.1.101 0060.2F7A.9C7A – Automatic
What command enables CDP on a switch?
S1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
S1(config)#cdp run
On a Layer 3 Switch what command do you use to allow dhcp request messages to be forwarded to a connected router for vlan 10 and 20?
S1(config)#int vlan 10
S1(config-if)#ip helper-address 10.1.1.254
S1(config-if)#int vlan 20
S1(config-if)#ip helper-address 10.1.1.254
T/F - If a router receives dhcp requests from a network it is not aware of will it allocate ip addresses?
False
Fix:
create static routes that point to those specific networks.
ex:
ip route 10.1.10.0 255.255.255.0 10.1.1.1
(network) (connected device ip address/switch etc.)
What command do you use to show the mac address table on a switch.
show mac address-table
You have a switch that is connected to an ip-phone and a host is connected to the ip phone. What command would you issue in interface config. mode on the switch to make the IP phone trust the CoS priority of incoming data packets generated by the attached host?
switchport priority extend trust
What command allows you to instruct an ip-phone to reclassify the CoS priority value that the host connected to the ip-phone assigned to it’s data packets?
switchport priority extend cos [value]
This command overrides the CoS priority value assigned by the host and tags the data packet with a CoS of 0, which is the efault value and is lower that the CoS value of 5 that the IP phone tags its voice packets with.
Overriding the CoS priority value ensures that voice packets will have a higher priority than the data packets and the voice packets will be given preference over the data packets as they are processed by the switch.
cos values range from 0-7 with 7 being the highest priority.