Dynamic Routing Flashcards

1
Q

What is a Router?

A

A network device with 2 major functions:
1. forwarding process: handles each packet as it arrives, looking up the outgoing line to use for it.
2. Filing and updating the routing table (routing algorithm)

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
2
Q

What properties are desireable for routing algorithms?

A

correctness, simplicity, robustness, stability, fairness and optimality.

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
3
Q

What conflict occurs between fairness and optimality?

A

Don’t shut down one network to make another more efficient. We want to maintain a Quality of Service, we prioritise some connections if needed.

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
4
Q

Describe what a sink tree is.

A

Pick a router “A” and draw a diagram to show all shortest paths from A to all other routers.

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
5
Q

Name and explain the two types of Routing Algorithms.

A

-Static (non adaptive) routing algorithms:
only use this in a very small network (1/2 routers). the choice of route to use is not done by the router but is made in advance (offline) and downloaded into the routers. It is error prone, labour heavy and cannot adapt to topology changes.
-Dynamic (adaptive) routing algorithms:
can change routing decisions if link goes down/capacity of link drops (traffic) i.e. changes in topology.

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
6
Q

Describe the flooding routing algorithm, is it static or dynamic?

A

Static
The flooding algorithm is only used in certain applications (military) because it is both inefficient and creates lots of duplicate packets. Every incoming packet is sent out on every outgoing line except the one it arrived on.

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
7
Q

Describe the shortest path routing algorithm, is it static or dynamic?

A

Dynamic
The shortest path algorithm uses dijkstra’s algorithm to make a routing take for each router, and create a sink tree for that table. For each router the tables initial values should be: shortest distance to itself = 0; shortest distant to all others = infinity.

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
8
Q

Describe Distance Vector Routing, is it static or dynamic?

A

Dynamic
In distance vector routing, each node measures the distance to its neighbours. Then each neighbour tells the node how much its distance to all other nodes is. Each node only has info about the next stop. It can make poor routing decisions if directions are not completely correct (i.e. if a router is down).
Distance vector routing took too long to converge and the delay metric was queue length (it didn’t take line bandwidth into account) so it was replaced by link state routing.

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
9
Q

Describe the routing algorithm that replaced distance vector routing.

A

Link State Routing:
-each node has a complete map of the topology
-if a node fails, each node can calculate a new route
-difficulty: all nodes need to have a consistent view of the network.

Basic principles:
1. Each router establishes a relationship (Adjacency) with its neighbors.
2. Each router generates Link State Advertisements (LSAs) which are distributed to all other routers (LSA = [link id, state of link, cost, neighbours])
3. Each router maintains a database of all received LSAs (topology/link state database) which describes the network as a graph with weighted edges.
4. Each router uses its link state database to run dijkstra’s algorithm.

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
10
Q

Describe the operation and purpose of the OSPF protocol.

A

Open Shortest Path First
Using OSPF each router must discover their neighbours and learn their net addresses.
They multicast Hello packets on all OSPF-enabled interfaces. If two routers share a link, they can become neighbours and form an adjacency. After nodes are discovered they exchange their databases:
The router then measures the delay or cost to each of their neighbours. The router constructs a packet telling all it has just learned and send this packet to all other routers in the network.
Link state Routing on each router

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
11
Q

Describe the format and purpose of an OSPF LSA.

A

LSAs have a LSA Header and LSA Data.
LSA Header has:
Link Age | Link type
Link state ID
advertising router
link sequence number
checksum | length

Link 1:
Link ID
Link Data
Link type|#TOS metrics| Metric

Link 2:
Link ID
Link Data
Link type|#TOS metrics| Metric

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
12
Q

What is hierarchical routing?

A

As the network grows, the size of routing tables, CPU usage and bandwidth demands for status updates increase proportionally. Eventually it becomes impractical for every router to maintain detailed information about every other router.

The routers are divided into ‘regions’ with each router knowing details about its own region. For huge networks, it may be necessary to group regions into clusters, clusters into zones, etc until we run out of names for aggregations.

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
13
Q

What is an autonomous system? How is routing done in AS?

A

a region of the internet that is administered by a single entity (e.g Eircoms backbone network, RISP)
Routing is done through intradomain routing (within an AS) and through interdomain routing (between 2 AS)

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
14
Q

What configuration commands are required to set up a router as a DHCP server for the local network with a host device?

A

/ip address add address=192.168.1.1/24 interface=ether1
/ip dhcp-server setup

first assign the IP address on the router interface and then run the DHCP server setup utility.

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
15
Q

What configuration commands are required to assign appropriate IP addresses and to also fully enable OSPF on a router?

A

assign ip addresses:
/ip address add address=10.1.1.2/24 interface=ether1

enable OSPF:
/routing ospf instance set default router-id=1.1.1.1
/routing ospf area name=backbone area-id=0.0.0.0
/routing ospf interface add interface=ether1 network-type=broadcast

How well did you know this?
1
Not at all
2
3
4
5
Perfectly
16
Q

What RouterOS commands would be required on a router to assign an appropriate IP address for an additional local area network and to ensure that the new IP range is reachable from the other routers in the network?

A

/ip address add address=192.168.3.1/24 interface=ether4
/routing ospf network add network=192.168.3.0/24