Cli Flashcards
enable
Enter privileged EXEC mode
configure terminal
Enter global configuration mode
hostname <name></name>
Set the device hostname
interface <type> <number></number></type>
Enter interface configuration mode
ip address <ip> <subnet></subnet></ip>
Assign IP address to interface
no shutdown
Enable an interface
show running-config
Display current configuration in RAM
show startup-config
Display saved configuration in NVRAM
copy running-config startup-config
Save running config to NVRAM
reload
Reboot the device
vlan <number></number>
Create a VLAN
name <vlan-name></vlan-name>
Name the VLAN
interface range <int-range></int-range>
Configure multiple interfaces
switchport mode access
Set interface to access mode
switchport access vlan <vlan-id></vlan-id>
Assign VLAN to access port
show vlan brief
Display VLAN configuration
show interfaces trunk
Display trunk port status
switchport mode trunk
Set interface to trunk mode
switchport trunk native vlan <vlan-id></vlan-id>
Set native VLAN on trunk port
switchport trunk allowed vlan <vlan-list></vlan-list>
Allow VLANs on trunk port
ip routing
Enable routing on a Layer 3 switch
ip route <dest> <mask> <next-hop></next-hop></mask></dest>
Configure a static route
show ip route
Show routing table
router ospf <process-id></process-id>
Enable OSPF routing
network <ip> <wildcard> area <area-id></area-id></wildcard></ip>
Define OSPF networks
show ip interface brief
Display IP interface summary
ping <ip-address></ip-address>
Send ICMP echo requests
traceroute <ip-address></ip-address>
Trace the path to a destination
enable secret <password></password>
Set encrypted privileged EXEC password
line console 0
Access console line config mode
password <password></password>
Set console line password
login
Enable login on console line
service password-encryption
Encrypt all plaintext passwords
access-list <number> permit <source></source> <wildcard></wildcard></number>
Create a standard ACL
ip access-group <number> in|out</number>
Apply ACL to an interface
ip nat inside
Configure NAT on the inside interface
ip nat outside
Configure NAT on the outside interface
ip nat inside source list <acl> interface <int> overload</int></acl>
Configure PAT
show version
Display IOS version and system information
show interfaces
Display interface status and statistics
show cdp neighbors
Display connected Cisco devices
show mac address-table
Show MAC address table
erase startup-config
Erase saved configuration in NVRAM