Chapter 8 Flashcards
An address destined for a single interface.
A packet sent to a unicast address is delivered to the
interface identified by that address.
Unicast
“One to One”
An address for a set of interfaces (typically belonging
to different nodes).
A packet sent to a multicast address will be delivered
to all interfaces identified by that address.
Multicast
“One to Many”
An address for a set of interfaces.
In most cases these interfaces belong to different
nodes.
A packet sent to an anycast address is delivered to the
closest interface as determined by the IGP.
Anycast
“One to Nearest” (Allocated from Unicast)
IPv6 provides many transition options including:
- Dual stack: Both IPv4 and IPv6 are configured and run simultaneously on the interface.
- IPv6-to-IPv4 (6to4) tunneling and IPv4-compatible tunneling.
- NAT protocol translation (NAT-PT) between IPv6 and IPv4.
IPv6 uses the “/prefix-length” CIDR notation to denote
how many bits in the IPv6 address represent the______
First half of the address
the following Layer 2 protocols can
dynamically create the IPv6 address interface ID:
- Ethernet (using the EUI-64 format discussed later)
- PPP
- HDLC
- NBMA, Frame Relay
Loopback address of local host.
::1/128
Link-local unicast address.
FE80::/10
1111 1110 10
Multicast addresses.
FF00::/8
Site-local addresses start with the prefix
FEC0::/10
Site-local addresses are no longer supported (deprecated)
by RFC 3879.
global unicast address
2001::/16
Reserved Multicast Address
All nodes on a link (link-local scope).
All routers on a link.
All routing information protocol (RIP) routers on a link.
FF02::1
FF02::2
FF02::9
Reserved Multicast Address
All solicited-node multicast addresses used for host autoconfiguration and neighbor discovery (similar to ARP in IPv4).
The xx:xxxx is the far right 24 bits of the corresponding unicast or anycast address of the node.’
FF02::1:FFxx:xxxx
All Network Time Protocol (NTP) servers
FF05::101
- Sent by a host to determine the link-layer address of a neighbor.
- Used to verify that a neighbor is still reachable.
- An __ is also used for Duplicate Address Detection (DAD)
Neighbor Solicitation (NS) 135
• A response to a NS message.
• A node may also send unsolicited NA to announce a link-layer
address change.
Neighbor Advertisement (NA) 136
• __s contain prefixes that are used for on-link determination or
address configuration, a suggested hop limit value, MTU value, etc.
• __s are sent either periodically, or in response to a RS
message.
Router Advertisement (RA) 134
When a host is booting it sends out an RS requesting routers to immediately generate an RA rather than wait for their next scheduled time.
Router Solicitation (RS) 133
The EUI-64 standard explains how it inserts a _________ in the middle at the 24th bit of the MAC address to create a unique 64-bit interface identifier.
16-bit 0xFFFE
Enable IPv6 on an interface without an explicit IPv6 address
ipv6 unnumbered
Enable the automatic configuration of IPv6 addresses.
ipv6 address autoconfig [default]
Alter the neighbor detection parameter.
ipv6 nd reachable-time
Add a neighbor router to the neighbor discovery cache
ipv6 neighbor ipv6-address interface-type interfacenumber
hardware-address
Enable an IPv6 RIP process on an interface.
R2(config)# interface s1/1.7
R2(config-subif)# ipv6 rip RIPTag enable
Configure the IPv6 RIP routing process.
Disable the split horizon route loop prevention feature
ipv6 router rip NAME
no split-horizon
Represents all OSPFv3 routers on the link-local scope, equivalent to 224.0.0.5 in OSPFv2.
Represents all designated routers (DRs) on the link-local scope, equivalent to 224.0.0.6 in OSPFv2.
FF02::5
FF02::6
Enable an OSPFv3 instance on an interface.
ipv6 ospf process-id area area-id [instance instance-id]
Specify the cost of sending a packet on an interface.
Router(config-if)#
ipv6 ospf cost interface-cost
range from 1 to 65535
Change the OSPF priority used in DR elections
Router(config-if)#
ipv6 ospf priority number-value
Define an area as a stub or totally-stub area.
Router(config-rtr)#
area 0 stub [no-summary]
Summarizes routes at an area boundary
R1(config)# ipv6 router ospf 1
R1(config-router)# area 1 range 2001:0DB8::/48
R1(config-router)# end
OSPFv3 Example 1
R1(config)# ipv6 router ospf 100 R1(config-rtr)# router-id 10.1.1.3 R1(config-rtr)# area 0 range 2001:410::/32 R1(config-rtr)# exit R1(config)# interface Serial0/0/1 R1(config-if)# ipv6 address 2001:410:FFFF:1::1/64 R1(config-if)# ipv6 ospf 100 area 0 R1(config-if)# exit R1(config)# interface Serial0/0/2 R1(config-if)# ipv6 address 3FFE:B00:FFFF:1::2/64 R1(config-if)# ipv6 ospf 100 area 1 R1(config-if)# R2(config)# ipv6 router ospf 100 R2(config-rtr)# router-id 10.1.1.4 R2(config-rtr)# exit R2(config)# interface Serial0/0/3 R2(config-if)# ipv6 address 3FFE:B00:FFFF:1::1/64 R2(config-if)# i
Enable the EIGRP for IPv6 process
Router(config-rtr)#
no shutdown
Identify the router as a stub router
Router(config-rtr)#
eigrp stub [receive-only | connected | static | summary
| redistributed]
Configures a summary aggregate address for an interface
ipv6 summary-address eigrp as-number ipv6-address
[admin-distance]
EIGRP for IPv6 Example
R2(config)# ipv6 unicast-routing R2(config)# R2(config)# interface Serial0/0/0.1 point-to-point R2(config-subif)# ipv6 eigrp 100 R2(config-subif)# interface Serial0/0/0.4 point-to-point R2(config-subif)# ipv6 eigrp 100 R2(config-subif)# ipv6 router eigrp 100 R2(config-rtr)# eigrp router-id 2.2.2.2 R2(config-rtr)# no shutdown R2(config-rtr)#
Configure the MBGP routing process parameters.
Router(config)#
router bgp autonomous-system
Define the BGP router ID.
Router(config-router)#
bgp router-id ip-address
Identify peer BGP routers.
Router(config-router)#
neighbor {ipv6-address | peer-group-name} remote-as
autonomous-system-number
Configure routing sessions that use standard IPv6 address prefixes.
Router(config-router)#
address-family ipv6 [unicast | multicast | vpnv6]
Identify peer BGP routers
Router(config-router)# or Router(config-router-af)#
neighbor ipv6-address activate
network network-number
apply a route map to filter incoming or outgoing MBGP routes.
Router(config-router)# or Router(config-router-af)#
neighbor ipv6-address route-map name {in | out}
MBGP Example
R1(config)# router bgp 1
R1(config-router)# bgp router-id 1.1.1.1
R1(config-router)# neighbor 2001:100:2:4::1 remote-as 100
R1(config-router)#
R1(config-router)# address-family ipv6
R1(config-router-af)# neighbor 2001:100:2:4::1 activate
R1(config-router-af)# redistribute connected
R1(config-router-af)# end
R1#
Command is the same as IPv4 and defines the route map conditions.
route-map map-tag [permit | deny] [sequence-number]
Router(config)#
Defines the conditions to match.
Router(config-route-map)#
match {conditions}
Defines the action to be taken on a match.
Router(config-route-map)#
set {actions}
Allows for detailed control of routes being redistributed into a routing
protocol.
Router(config-router)#
redistribute protocol [process-id] route-map map-tag
Matches any routes that have a destination network number IPv6
address that is permitted by a standard or extended ACL
Matches any routes that have a next-hop router IPv6 address that
is passed by one of the ACLs specified
Matches routes that have been advertised by routers and access
servers at the IPv6 address that is specified by the ACLs
match ipv6 address
match ipv6 next-hop
match ipv6 route-source
Specify a prefix-list or ACL to match.
Router(config-route-map)#
match ipv6 address {prefix-list prefix-list-name |
access-list-name}
Specify where to forward IPv6 packets that pass a match clause.
Router(config-route-map)#
set ipv6 next-hop global-ipv6-address [global-ipv6-
address…]
Apply the PBR route map to an interface.
Router(config-if)#
ipv6 policy route-map route-map-name
Identify a route map to use for local policy routing.
Router(config)#
ipv6 local policy route-map route-map-name
IPv6 PBR Example
R1(config)# route-map PBR-SOURCE-ADDRESS permit 10
R1(config-route-map)# match ipv6 address SOURCE-104
R1(config-route-map)# set ipv6 next-hop 123::3
R1(config-route-map)# exit
R1(config)# ipv6 access-list SOURCE-104
R1(config-ipv6-acl)# permit ipv6 104::/64 any
R1(config-ipv6-acl)# exit
R1(config)# interface fa0/0
R1(config-if)# ipv6 policy route-map PBR-SOURCE-ADDRESS
R1(config-if)#
Redistribution Example 1
R1(config)# router bgp 12
R1(config-router)# address-family ipv6 unicast
R1(config-router-af)# redistribute rip R1R3 include-connected
R2(config)# router bgp 12
R2(config-router)# address-family ipv6 unicast
R2(config-router-af)# redistribute ospf 1 include-connected
Redistribution Example 2
R1(config)# ipv6 router rip R1R3 R1(config-rtr)# redistribute bgp 12 R1(config-rtr)# redistribute connected R1(config-rtr)# exit R1(config)# R1(config)# router bgp 12 R1(config-router)# address-family ipv6 unicast R1(config-router-af)# bgp redistribute-internal R1(config-router-af)#
Redistribution Example 3
R2(config)# ipv6 router ospf 1 R2(config-rtr)# redistribute bgp 12 R2(config-rtr)# redistribute connected R2(config-rtr)# exit R2(config)# router bgp 12 R2(config-router)# address-family ipv6 unicast R2(config-router-af)# bgp redistribute-internal R2(config-router-af)#
Dual-Stack Example
R1(config)# interface fa0/0
R1(config-if)# ip address 10.10.10.1 255.255.255.0
R1(config-if)# ipv6 address 2001:12::1/64
Manual IPv6 Tunnel Example
R2(config)# interface tunnel 12
R2(config-if)#
*Aug 16 09:38:47.532: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel12,
changed state to down
R2(config-if)# no ip address
R2(config-if)# ipv6 address 12::2/64
R2(config-if)# tunnel source loopback 102
R2(config-if)# tunnel destination 10.1.1.1
R2(config-if)#
*Aug 16 09:39:24.056: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel12,
changed state to up
R2(config-if)# tunnel mode ipv6ip
6to4 Limitations
Only static routes or BGP are supported.
6to4 Tunnel Example
R1(config)# interface tunnel 12
R1(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel12, changed state to down
R1(config-if)# no ip address
R1(config-if)# ipv6 address 2002:AC10:6501::/128
R1(config-if)# tunnel source loopback 101
R1(config-if)# tunnel mode ipv6ip 6to4
R1(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel12, changed state to up
R1(config-if)# exit
R1(config)# ipv6 route 2002::/16 tunnel 12
R1(config)# ipv6 route 24::/64 2002:AC10:6601::
R1(config)#
- It is used to connect IPv6 domains over an IPv4 network.
* It embeds an IPv4 address within the IPv6 address.
Intra-Site Automatic Tunnel Addressing Protocol
ISATAP
ISATAP Tunnel Example
R1(config)# interface tunnel 12
R1(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel12, changed state to down
R1(config-if)# no ip address
R1(config-if)# ipv6 address 12:12::/64 eui-64
R1(config-if)# tunnel source loopback 101
R1(config-if)# tunnel mode ipv6ip isatap
R1(config-if)# exit
%LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel12, changed state to up
R2(config)# ipv6 route 24::/64 tunnel12 FE80::5EFE:AC10:6601
R2(config)#
Instead, it can be used in situations where direct communication between IPv6-only and IPv4-only networks is desired.
NAT-PT
A __ is required in NAT-PT architectures.
DNS
NAT-PT uses a ___ IPv6 network prefix to direct all IPv6 traffic that needs to be translated to the NAT-PT router.
96-bit
Configure IPv4-to-IPv6 static address translation using NAT-PT.
Router(config)#
ipv6 nat v4v6 source ipv4-address ipv6-address
Configure IPv6-to-IPv4 static address translation using NAT-PT.
Router(config)#
ipv6 nat v6v4 source ipv6-address ipv4-address
Define the network prefix that NAT-PT will translate.
Router(config)# or Router(config-if)#
ipv6 nat prefix ipv6-prefix/prefix-length
Identify the participating NAT-PT interfaces.
Router(config-if)#
ipv6 nat
Static NAT-PT Example
R1(config)# interface s0/0/0
R1(config-if)# ipv6 nat
R1(config)# ipv6 nat v6v4 source 14::4 172.16.123.100
R1(config)# ipv6 nat v4v6 source 172.16.123.2 1144::1
R1(config)#
R1(config)# ipv6 nat prefix 1144::/96
R1(config)#
Define a pool of IPv4 addresses for NAT-PT.
ipv6 nat v6v4 pool name start-ipv4 end-ipv4 prefixlength
prefix-length
R1(config)# ipv6 nat v6v4 pool POOL-12 172.16.12.100 172.16.12.101 prefix-length 24
R1(config)# ipv6 nat v6v4 pool POOL-123 172.16.123.100 172.16.123.101 prefix-length 24
R1(config)#
Define a pool of IPv6 addresses for NAT-PT.
Router(config)#
ipv6 nat v4v6 pool name start-ipv6 end-ipv6 prefixlength
prefix-length
R1(config)# ipv6 nat v4v6 pool POOL-1144 1144::1 1144::2 prefix-length 96
R1(config)#